aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-05-11 20:56:51 +0000
committerNicolas Thill <nico@openwrt.org>2008-05-11 20:56:51 +0000
commit2f18c70fb64b794976253267fd3dd6c693ae7799 (patch)
treee6a114118dd9c4198851a6b807c42cc48be322a7 /include/kernel.mk
parent78aa6df4e3952a1d5ca649a4e248bc4e7db30ce2 (diff)
downloadmaster-187ad058-2f18c70fb64b794976253267fd3dd6c693ae7799.tar.gz
master-187ad058-2f18c70fb64b794976253267fd3dd6c693ae7799.tar.bz2
master-187ad058-2f18c70fb64b794976253267fd3dd6c693ae7799.zip
add a macro to compare kernel patch versions and use it for crypto and watchdog changes in 2.6.24+ kernels (closes: #3402)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11115 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel.mk')
-rw-r--r--include/kernel.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 52355dcdd3..b80c3b63ff 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -145,3 +145,7 @@ define AutoLoad
add_module $(1) "$(2)";
endef
+define CompareKernelPatchVer
+ $(shell [ $$(echo $(1) | tr . 0) -$(2) $$(echo $(3) | tr . 0) ] && echo 1 || echo 0)
+endef
+