aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-08 15:23:11 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-08 15:23:11 +0000
commit63b45c1a5d8d59c5f4a6c26542fa51d1b89a7fd0 (patch)
tree283cc106e88a9c1f4adde1d7f45c847b09a98c67 /include/kernel-defaults.mk
parent50d5d3d521d4818215814dbf4e9a24e26f1ce221 (diff)
downloadmaster-187ad058-63b45c1a5d8d59c5f4a6c26542fa51d1b89a7fd0.tar.gz
master-187ad058-63b45c1a5d8d59c5f4a6c26542fa51d1b89a7fd0.tar.bz2
master-187ad058-63b45c1a5d8d59c5f4a6c26542fa51d1b89a7fd0.zip
include: calculate md5sum over sorted kernel config symbol list and incorperate it into the kernel metapackage version, make kmods depend on this specific version.
The aim of this change is to invalidate kmods which are built against a different kernel config on the opkg metadata level. Manual copying and insmod of custom *.ko files, e.g. for development purpose, is still possible. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29686 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 5fd27ae7cd..52ce03776c 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -89,6 +89,7 @@ define Kernel/Configure/Default
$(call Kernel/SetInitramfs)
-$(_SINGLE)$(MAKE) $(KERNEL_MAKEOPTS) oldconfig prepare scripts
rm -rf $(KERNEL_BUILD_DIR)/modules
+ $(SH_FUNC) grep '=[ym]' $(LINUX_DIR)/.config | LC_ALL=C sort | md5s > $(LINUX_DIR)/.vermagic
endef
define Kernel/CompileModules/Default