aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-defaults.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-04-12 21:21:49 +0000
committerJohn Crispin <blogic@openwrt.org>2014-04-12 21:21:49 +0000
commit12bb716ac3dacb9fe835f2adcb23c4234d74003c (patch)
tree6b15651ee1a9e41fc8e642baaf49116acad14ac3 /include/kernel-defaults.mk
parent9f3447fc0e3c5933c2b215bb6298b525404f0283 (diff)
downloadmaster-187ad058-12bb716ac3dacb9fe835f2adcb23c4234d74003c.tar.gz
master-187ad058-12bb716ac3dacb9fe835f2adcb23c4234d74003c.tar.bz2
master-187ad058-12bb716ac3dacb9fe835f2adcb23c4234d74003c.zip
sparse: add as a new package selectable from the config
This change does multiple things, all related to enable sparse usage as a static analysis tool selectable from the OpenWrt configuration: *add a KERNEL_SPARSE option in the config to add sparse to the kernel build (through the C=1 option usage) *add sparse as a new host tools. It will get selected automatically when the above option will be enabled Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40490 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-defaults.mk')
-rw-r--r--include/kernel-defaults.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index caaa09d51d..322aeed5fa 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -24,6 +24,10 @@ ifneq (,$(KERNEL_CC))
KERNEL_MAKEOPTS += CC="$(KERNEL_CC)"
endif
+ifdef CONFIG_USE_SPARSE
+ KERNEL_MAKEOPTS += C=1 CHECK=$(STAGING_DIR_HOST)/bin/sparse
+endif
+
export HOST_EXTRACFLAGS=-I$(STAGING_DIR_HOST)/include
# defined in quilt.mk