aboutsummaryrefslogtreecommitdiffstats
path: root/include/kernel-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-16 16:59:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-16 16:59:44 +0000
commitb4f853be1898f720784fbdf3ee6718188c6c335c (patch)
tree90caca550f3e130f8ea4493e1f8691dbb03e12c5 /include/kernel-build.mk
parent86666298d70fb34fc6e383e1aa15e4ae1f4d4836 (diff)
downloadmaster-187ad058-b4f853be1898f720784fbdf3ee6718188c6c335c.tar.gz
master-187ad058-b4f853be1898f720784fbdf3ee6718188c6c335c.tar.bz2
master-187ad058-b4f853be1898f720784fbdf3ee6718188c6c335c.zip
add top-level kernel_menuconfig target to unpack and reconfigure the kernel - uses config.pl to generate target/linux/*/config and config-diff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6310 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/kernel-build.mk')
-rw-r--r--include/kernel-build.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 1ac847e93c..24e7e85828 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -226,6 +226,13 @@ $(eval $(call shexport,Target/Description))
download: $(DL_DIR)/$(LINUX_SOURCE)
prepare: $(LINUX_DIR)/.configured $(TMP_DIR)/.kernel.mk
compile: $(LINUX_DIR)/.modules
+menuconfig: $(LINUX_DIR)/.configured FORCE
+ $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) menuconfig
+ $(SCRIPT_DIR)/config.pl $(LINUX_DIR)/.config > $(PLATFORM_DIR)/config
+ifeq ($(KERNEL),2.6)
+ $(SCRIPT_DIR)/config.pl '>' $(GENERIC_PLATFORM_DIR)/config-template $(LINUX_DIR)/.config > $(PLATFORM_DIR)/config-diff
+endif
+
install: $(LINUX_DIR)/.image
clean: FORCE