aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-29 01:30:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-29 01:30:48 +0000
commitf460eb1cdbb88e51b2cb128261737931ae215774 (patch)
tree36b3ba353b28b629ca2104160377ab17b28d0b2a /include/image.mk
parentb63212e0a6cc6fbc554a2b593f79d89126bf7222 (diff)
downloadmaster-187ad058-f460eb1cdbb88e51b2cb128261737931ae215774.tar.gz
master-187ad058-f460eb1cdbb88e51b2cb128261737931ae215774.tar.bz2
master-187ad058-f460eb1cdbb88e51b2cb128261737931ae215774.zip
fixes for a few build errors on osx without fink
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7065 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 0e6a7cdbea..f814f61d77 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -7,6 +7,7 @@
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/host.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -79,9 +80,9 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
- find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
- find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+ find $(BUILD_DIR)/root -type f -perm +0100 | $(XARGS) chmod 0755
+ find $(BUILD_DIR)/root -type d | $(XARGS) chmod 0755
mkdir -p $(BUILD_DIR)/root/tmp
chmod 0777 $(BUILD_DIR)/root/tmp
endef