aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-18 00:11:20 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-18 00:11:20 +0000
commitf0662fc03c30e8405117fe6692c4cace94092f2d (patch)
tree55b255dc31ba2c173d58808bf257380b84c41b78 /include/image.mk
parent9252c452cd6e76c8c004642b060b0d0390b80a4b (diff)
downloadmaster-187ad058-f0662fc03c30e8405117fe6692c4cace94092f2d.tar.gz
master-187ad058-f0662fc03c30e8405117fe6692c4cace94092f2d.tar.bz2
master-187ad058-f0662fc03c30e8405117fe6692c4cace94092f2d.zip
build: set owner root for all files on ubifs creation
When creating an image it makes no sense to have files owned by the uid and gid on the host (and even creates a bug when for example dropbear authorized_keys is included via env/files). Signed-off-by: Joris de Vries <joris@apptrician.nl> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38442 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 729929f9da..c7da0600c3 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -139,6 +139,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \
--jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
+ --squash-uids \
-o $(KDIR)/root.ubifs \
-d $(TARGET_DIR)
endif