aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-12-04 22:59:05 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-12-04 22:59:05 +0000
commit9a95c59fbe8f66f4ea6774dd9596dfc7c73cf25d (patch)
tree99002c9bf28013269c7e82996bb82dcf34ed686b /include/image.mk
parent46e32ed7fa988e35451e340f8450705d5f5d891f (diff)
downloadmaster-187ad058-9a95c59fbe8f66f4ea6774dd9596dfc7c73cf25d.tar.gz
master-187ad058-9a95c59fbe8f66f4ea6774dd9596dfc7c73cf25d.tar.bz2
master-187ad058-9a95c59fbe8f66f4ea6774dd9596dfc7c73cf25d.zip
Revert "include/image.mk: call Image/Build/{cpiogz,targz}"
This breaks on platforms building their own targz/cpioz images. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34498 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index 7758c9a90a..503115ddb0 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -109,7 +109,6 @@ endif
ifneq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),)
define Image/mkfs/cpiogz
( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
- $(call Image/Build,cpiogz)
endef
endif
@@ -117,7 +116,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_TARGZ),)
define Image/mkfs/targz
# Preserve permissions (-p) when building as non-root user
$(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
- $(call Image/Build,targz)
endef
endif