aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 23:52:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 23:52:17 +0000
commit2033a6135ab33724276e224c63afa5e8a0406001 (patch)
tree334cd8fa09f7ca5cc72956b65db3be3db556a0f3 /include/host-build.mk
parent193971f1b843b9a2a673b95e9a9d602e78743ea7 (diff)
downloadmaster-187ad058-2033a6135ab33724276e224c63afa5e8a0406001.tar.gz
master-187ad058-2033a6135ab33724276e224c63afa5e8a0406001.tar.bz2
master-187ad058-2033a6135ab33724276e224c63afa5e8a0406001.zip
fix a rebuild bug related to quilt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8255 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index e934c91c66..f4b6b449e1 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -80,7 +80,7 @@ ifneq ($(strip $(PKG_SOURCE)),)
$(STAMP_PREPARED): $(DL_DIR)/$(PKG_SOURCE)
endif
-ifneq ($(CONFIG_AUTOREBUILD),)
+ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
define HostBuild/Autoclean
$(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
$(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
@@ -105,7 +105,6 @@ define HostBuild
$(STAMP_BUILT): $(STAMP_CONFIGURED)
$(call Build/Compile)
- @$(NO_TRACE_MAKE) $(PKG_BUILD_DIR)/.dep_files
touch $$@
$(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed: $(STAMP_BUILT)