aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-08-02 12:07:14 +0000
committerMike Baker <mbm@openwrt.org>2006-08-02 12:07:14 +0000
commitcfa303fd2b70131f26c8a62a172bded7ccce50e0 (patch)
tree1f46805a8efe8095d96eaf839755598cdf9b0264 /Makefile
parentb9475586bd601551b2e9b421240ccbdf8e822335 (diff)
downloadmaster-187ad058-cfa303fd2b70131f26c8a62a172bded7ccce50e0.tar.gz
master-187ad058-cfa303fd2b70131f26c8a62a172bded7ccce50e0.tar.bz2
master-187ad058-cfa303fd2b70131f26c8a62a172bded7ccce50e0.zip
minor makefile tweaks
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4393 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 85091f618e..a520ffde2d 100644
--- a/Makefile
+++ b/Makefile
@@ -14,18 +14,17 @@ RELEASE:=Kamikaze
# Just run 'make menuconfig', configure stuff, then run 'make'.
# You shouldn't need to mess with anything beyond this point...
#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+export TOPDIR=${shell pwd}
include $(TOPDIR)/include/verbose.mk
OPENWRTVERSION:=$(RELEASE)
ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+ OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+ REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+ ifneq ($(REV),)
+ OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+ endif
endif
export OPENWRTVERSION
@@ -40,7 +39,7 @@ endif
@echo Collecting package info...
@-for dir in package/*/; do \
echo Source-Makefile: $${dir}Makefile; \
- $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+ $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || echo "ERROR: please fix package/$${dir}/Makefile" >&2; \
done > $@
.config.in: .pkginfo
@@ -129,5 +128,6 @@ distclean: dirclean config-clean
.SILENT: clean dirclean distclean config-clean download world
+FORCE: ;
.PHONY: FORCE
-FORCE:
+%: ;