aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-10 20:57:35 +0000
committerMike Baker <mbm@openwrt.org>2006-05-10 20:57:35 +0000
commit0ce063db66999ec583f94a2ecd07ea208730b769 (patch)
tree819256692a2921f488441db5319b36a85a966d9b /Makefile
parent6e5aca757c365260e6b95cee4d62512729d14ede (diff)
downloadmaster-187ad058-0ce063db66999ec583f94a2ecd07ea208730b769.tar.gz
master-187ad058-0ce063db66999ec583f94a2ecd07ea208730b769.tar.bz2
master-187ad058-0ce063db66999ec583f94a2ecd07ea208730b769.zip
change phony targets to FORCE (easier to read)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3757 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index ec1e3677ab..c323a9c24c 100644
--- a/Makefile
+++ b/Makefile
@@ -38,21 +38,19 @@ endif
endif
export OPENWRTVERSION
-.pkginfo:
+.pkginfo: FORCE
+ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
@echo Collecting package info...
@-for makefile in package/*/Makefile; do \
echo Source-Makefile: $$makefile; \
$(MAKE) DUMP=1 -f $$makefile 2>&- || true; \
done > $@
-
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
-.pkginfo: pkginfo-clean
endif
.config.in: .pkginfo
./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
-pkginfo-clean:
+pkginfo-clean: FORCE
-rm -f .pkginfo .config.in
scripts/config/mconf: .config.in
@@ -70,6 +68,5 @@ config: scripts/config/conf
config-clean:
$(MAKE) -C scripts/config clean
-.PHONY: pkginfo-clean
-
-
+.PHONY: FORCE
+FORCE: