aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-02-22 22:35:08 +0000
committerTim Yardley <lst@openwrt.org>2007-02-22 22:35:08 +0000
commitfcbe667a8112d994e878d5c01e169c076ce01b91 (patch)
tree88a4b81701a303eac2e2c4e4c64c1d555aa68a23
parentef6f0dcf0e612325d00d1ce62e36ff23e7051817 (diff)
downloadmaster-187ad058-fcbe667a8112d994e878d5c01e169c076ce01b91.tar.gz
master-187ad058-fcbe667a8112d994e878d5c01e169c076ce01b91.tar.bz2
master-187ad058-fcbe667a8112d994e878d5c01e169c076ce01b91.zip
make maxinodes configureable for ext2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6345 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in17
-rw-r--r--include/image.mk2
2 files changed, 14 insertions, 5 deletions
diff --git a/Config.in b/Config.in
index 2efd1ce25d..65c7dc6c3a 100644
--- a/Config.in
+++ b/Config.in
@@ -103,10 +103,19 @@ comment "Image Options"
source "target/linux/*/image/Config.in"
- config TARGET_ROOTFS_FSPART
- int "Filesystem part size (in MB)"
- depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
- default 16
+ config TARGET_ROOTFS_FSPART
+ int "Filesystem part size (in MB)"
+ depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+ default 16
+ help
+ Allows you to change the filesystem partition size
+
+ config TARGET_ROOTFS_MAXINODE
+ int "Maximum number of inodes in filesystem"
+ depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+ default 1500
+ help
+ Allows you to change the maximum number of inodes in the filesystem
endmenu
diff --git a/include/image.mk b/include/image.mk
index 4f638f0260..ec0512f904 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -56,7 +56,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))
define Image/mkfs/ext2
- $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I 1500 -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
+ $(STAGING_DIR)/bin/genext2fs -U -b $(E2SIZE) -I $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(BUILD_DIR)/root/ $(KDIR)/root.ext2
$(call Image/Build,ext2)
endef
endif