aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-14 00:00:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-14 00:00:55 +0000
commitea5b63b40aa81cf62f5e1d53044e7380e9477aae (patch)
tree2301f8af8daae3a1a1cb74f878ea270f69ef3b50
parent6b5fcf103d4dfa99f02b44d0bb8bc7082c1d782f (diff)
downloadmaster-187ad058-ea5b63b40aa81cf62f5e1d53044e7380e9477aae.tar.gz
master-187ad058-ea5b63b40aa81cf62f5e1d53044e7380e9477aae.tar.bz2
master-187ad058-ea5b63b40aa81cf62f5e1d53044e7380e9477aae.zip
build: set CCACHE_DIR for host builds
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45427 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/host-build.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 2f3c53d098..760d38b371 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -131,6 +131,7 @@ define Host/Exports/Default
$(1) : export STAGING_PREFIX=$$(STAGING_DIR_HOST)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+ $(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache
endef
Host/Exports=$(Host/Exports/Default)