aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-02 07:42:03 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-02 07:42:03 +0000
commitd55205b171b6cc2746a89be87f45d56ae2588eee (patch)
treefc9542dc60eb03cd1e69ec0aa1f0ceffde342a1f
parentb2d283fb2f54f8b910502a8911cb00408c766756 (diff)
downloadmaster-187ad058-d55205b171b6cc2746a89be87f45d56ae2588eee.tar.gz
master-187ad058-d55205b171b6cc2746a89be87f45d56ae2588eee.tar.bz2
master-187ad058-d55205b171b6cc2746a89be87f45d56ae2588eee.zip
ar71xx: fix initramfs image generation for Cameo933x profiles
Initramfs images are not generated for profiles which are using the squashfs-only template. Add the missing 'Image/Build/Template/squashfs-only/initramfs' to fix that. Also, 'Image/Build/Cameo933x/initramfs' uses wrong parameters for 'MkuImageLzma/initramfs' due to a misplaced commma. Remove that to fix the generated initramfs images. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37871 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b755a9d324..e78679093d 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -386,7 +386,7 @@ define Image/Build/Cameo933x
endef
define Image/Build/Cameo933x/initramfs
- $(call MkuImageLzma/initramfs,$(2),$(3),$(cameo933x_mtdlayout))
+ $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo933x_mtdlayout))
endef
define Image/Build/Cameo933x_8M
@@ -816,6 +816,10 @@ define Image/Build/Template/squashfs-only/squashfs
$(call Image/Build/$(1),squashfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
endef
+define Image/Build/Template/squashfs-only/initramfs
+ $(call Image/Build/$(1)/initramfs,initramfs,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
+endef
+
define Image/Build/Template/64k/loader
$(call Image/Build/$(1)/loader,$(2),$(3),$(4),$(5),$(6),$(7),$(8))
endef