aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2016-01-24 12:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2016-01-24 12:36:15 +0000
commitd49ca69e9141b4414557807f7c56cc408156b54d (patch)
tree641061ed274a312216fcf9a439485373fa400295
parentca353b07da6d8cd82e90f79fb600787b12128011 (diff)
downloadmaster-187ad058-d49ca69e9141b4414557807f7c56cc408156b54d.tar.gz
master-187ad058-d49ca69e9141b4414557807f7c56cc408156b54d.tar.bz2
master-187ad058-d49ca69e9141b4414557807f7c56cc408156b54d.zip
generic: fix relocate build with binutils 2.25.1
The new .abiflags section was kept, pushing the appended arguments to the wrong offset and causing it to read the section instead, making it fail on boot. Fix this by dropping this section as well as the other sections. Closes #21679. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48474 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/generic/image/relocate/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/generic/image/relocate/Makefile b/target/linux/generic/image/relocate/Makefile
index 5f6ebeb096..19e701968f 100644
--- a/target/linux/generic/image/relocate/Makefile
+++ b/target/linux/generic/image/relocate/Makefile
@@ -29,7 +29,8 @@ LD := $(CROSS_COMPILE)ld
OBJCOPY := $(CROSS_COMPILE)objcopy
OBJDUMP := $(CROSS_COMPILE)objdump
-BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
+BIN_FLAGS := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
+ -R .MIPS.abiflags -S
CFLAGS = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \