diff options
author | Luka Perkov <luka@openwrt.org> | 2013-11-14 01:35:21 +0000 |
---|---|---|
committer | Luka Perkov <luka@openwrt.org> | 2013-11-14 01:35:21 +0000 |
commit | c872fd9a560adc959c914d1678e2b69be69cb819 (patch) | |
tree | bafb50e264dc3954d75a0115d215f6433acf816d | |
parent | c94aeffb154667efcd7acad58a1598d8ccb06e22 (diff) | |
download | master-187ad058-c872fd9a560adc959c914d1678e2b69be69cb819.tar.gz master-187ad058-c872fd9a560adc959c914d1678e2b69be69cb819.tar.bz2 master-187ad058-c872fd9a560adc959c914d1678e2b69be69cb819.zip |
image: don't force ubifs journal size
Small journal size can lead to problems if nand flash is too big. By default
ubifs will use ~12% of volume size or a maximum of 8MiB.
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38799 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 2 | ||||
-rw-r--r-- | include/image.mk | 2 |
2 files changed, 2 insertions, 2 deletions
@@ -143,7 +143,7 @@ menu "Target Images" config TARGET_UBIFS_JOURNAL_SIZE string prompt "journal size" if TARGET_ROOTFS_UBIFS - default "512KiB" + default "" config TARGET_UBIFS_SQUASH_UIDS bool "squash uids" if TARGET_ROOTFS_UBIFS diff --git a/include/image.mk b/include/image.mk index 71822de980..aa565951a9 100644 --- a/include/image.mk +++ b/include/image.mk @@ -142,7 +142,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),) $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \ $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \ $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \ - --jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \ + $(if $(shell echo $(CONFIG_TARGET_UBIFS_JOURNAL_SIZE)),--jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE)) \ --squash-uids \ -o $(KDIR)/root.ubifs \ -d $(TARGET_DIR) |