aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-09-30 12:55:30 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-09-30 12:55:30 +0000
commitc1999307b67c3fdd2e6ad01b526bbd334a293b8c (patch)
tree14ebe67b31b11a195815e0d9a03cb344ba3730db
parentfbb445d7e4a64a83966e5f545c1176b778fc3c6f (diff)
downloadmaster-187ad058-c1999307b67c3fdd2e6ad01b526bbd334a293b8c.tar.gz
master-187ad058-c1999307b67c3fdd2e6ad01b526bbd334a293b8c.tar.bz2
master-187ad058-c1999307b67c3fdd2e6ad01b526bbd334a293b8c.zip
[package] add kmod-hwmon-lm95241
This allows building the module for the national lm95241 i2c temperature sensor. Signed-off-by: Daniel Golle <dgolle@allnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28335 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index ebbe7cfabc..57dd5684cb 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -89,6 +89,20 @@ endef
$(eval $(call KernelPackage,hwmon-lm90))
+define KernelPackage/hwmon-lm95241
+ TITLE:=LM95241 monitoring support
+ KCONFIG:=CONFIG_SENSORS_LM95241
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm95241.ko
+ AUTOLOAD:=$(call AutoLoad,60,lm95241)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm95241/description
+ Kernel module for LM95241 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm95241))
+
define KernelPackage/hwmon-pc87360
TITLE:=PC87360 monitoring support