aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-06-21 16:52:48 +0000
committerJohn Crispin <blogic@openwrt.org>2013-06-21 16:52:48 +0000
commitb7ca061d02d0ab42b6217714f5fbf190a9ae407a (patch)
tree1b7acb9d8c63a7d7739275f831de1e726b63e00c
parentabf153ccd03a1c89d1e27845c72e67fbe7051289 (diff)
downloadmaster-187ad058-b7ca061d02d0ab42b6217714f5fbf190a9ae407a.tar.gz
master-187ad058-b7ca061d02d0ab42b6217714f5fbf190a9ae407a.tar.bz2
master-187ad058-b7ca061d02d0ab42b6217714f5fbf190a9ae407a.zip
util-linux: fix endianess bug and stage libraries properly
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36985 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/util-linux/Makefile10
-rw-r--r--package/util-linux/patches/002-fix-endianess.patch13
2 files changed, 18 insertions, 5 deletions
diff --git a/package/util-linux/Makefile b/package/util-linux/Makefile
index 7deb77d0af..ed2c10f172 100644
--- a/package/util-linux/Makefile
+++ b/package/util-linux/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
PKG_VERSION:=2.21.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.21
@@ -33,7 +33,7 @@ endef
CONFIGURE_ARGS += \
--enable-new-mount \
--with-ncurses \
- --disable-nls \
+ --disable-nls \
--disable-tls \
--without-udev
@@ -58,9 +58,9 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/libuuid/src/uuid.h $(1)/usr/include/uuid
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.{a,so.*} $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.{a,so.*} $(1)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.{a,so.*} $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libblkid/src/.libs/libblkid.{a,so*} $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libmount/src/.libs/libmount.{a,so*} $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libuuid/src/.libs/libuuid.{a,so*} $(1)/usr/lib
endef
define Package/libblkid
diff --git a/package/util-linux/patches/002-fix-endianess.patch b/package/util-linux/patches/002-fix-endianess.patch
new file mode 100644
index 0000000000..4c59932cda
--- /dev/null
+++ b/package/util-linux/patches/002-fix-endianess.patch
@@ -0,0 +1,13 @@
+Index: util-linux-2.21.2/libblkid/src/superblocks/swap.c
+===================================================================
+--- util-linux-2.21.2.orig/libblkid/src/superblocks/swap.c 2012-05-15 13:51:45.814410455 +0200
++++ util-linux-2.21.2/libblkid/src/superblocks/swap.c 2013-06-12 23:23:03.270742199 +0200
+@@ -48,7 +48,7 @@
+
+ /* SWAPSPACE2 - check for wrong version or zeroed pagecount */
+ if (strcmp(version, "2") == 0 &&
+- (hdr->version != 1 || hdr->lastpage == 0))
++ ((hdr->version != 1 && swab32(hdr->version) != 1) || hdr->lastpage == 0))
+ return -1;
+
+ /* arbitrary sanity check.. is there any garbage down there? */