aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-08 13:30:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-08 13:30:54 +0000
commita263dc5a12daab294adf41986f67edeee3b0ad6b (patch)
tree863e5e03a3ea10cf90d51168e8d5dfe02c1c685f
parentfb95e63a50371c75ca5411c71ef3b3b3adaad02d (diff)
downloadmaster-187ad058-a263dc5a12daab294adf41986f67edeee3b0ad6b.tar.gz
master-187ad058-a263dc5a12daab294adf41986f67edeee3b0ad6b.tar.bz2
master-187ad058-a263dc5a12daab294adf41986f67edeee3b0ad6b.zip
add further countermeasures against the git core.autocrlf option (fixes #9075)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31650 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/toplevel.mk1
-rwxr-xr-xscripts/feeds1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 9a60139329..721d14c486 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -24,6 +24,7 @@ export OPENWRTVERSION
export IS_TTY=$(shell tty -s && echo 1 || echo 0)
export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
+export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
# prevent perforce from messing with the patch utility
unexport P4PORT P4USER P4CONFIG P4CLIENT
diff --git a/scripts/feeds b/scripts/feeds
index b8c6825ed0..2c0baa6584 100755
--- a/scripts/feeds
+++ b/scripts/feeds
@@ -10,6 +10,7 @@ use Cwd 'abs_path';
chdir "$FindBin::Bin/..";
$ENV{TOPDIR}=getcwd();
+$ENV{GIT_CONFIG_PARAMETERS}="'core.autocrlf=false'";
my $mk=`which gmake`; # select the right 'make' program
chomp($mk); # trim trailing newline