aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-10-25 01:48:02 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-10-25 01:48:02 +0000
commita18061e8b951a01d886587f605d602ff744c8f72 (patch)
tree164ec27aee113ab2c1ece84aabb4fb03c8b1c4cd
parent80c6f0c1253e5be60c34c0e5d4c85c0dc35f45ad (diff)
downloadmaster-187ad058-a18061e8b951a01d886587f605d602ff744c8f72.tar.gz
master-187ad058-a18061e8b951a01d886587f605d602ff744c8f72.tar.bz2
master-187ad058-a18061e8b951a01d886587f605d602ff744c8f72.zip
include: handle LZ4 compression scheme
Kernel 3.12 now offers LZ4 compression which will make initramfs builds fail because we do not know how to substitute the relevant config symbols, fix that. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38533 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-defaults.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 48f2b2ab75..96f2b2cbe6 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -81,6 +81,7 @@ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
echo -e "$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZMA),CONFIG_INITRAMFS_COMPRESSION_LZMA=y\nCONFIG_RD_LZMA=y,# CONFIG_INITRAMFS_COMPRESSION_LZMA is not set\n# CONFIG_RD_LZMA is not set)" >> $(LINUX_DIR)/.config
echo -e "$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZO),CONFIG_INITRAMFS_COMPRESSION_LZO=y\nCONFIG_RD_LZO=y,# CONFIG_INITRAMFS_COMPRESSION_LZO is not set\n# CONFIG_RD_LZO is not set)" >> $(LINUX_DIR)/.config
echo -e "$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_XZ),CONFIG_INITRAMFS_COMPRESSION_XZ=y\nCONFIG_RD_XZ=y,# CONFIG_INITRAMFS_COMPRESSION_XZ is not set\n# CONFIG_RD_XZ is not set)" >> $(LINUX_DIR)/.config
+ echo -e "$(if $(CONFIG_TARGET_INITRAMFS_COMPRESSION_LZ4),CONFIG_INITRAMFS_COMPRESSION_LZ4=y\nCONFIG_RD_LZ4=y,# CONFIG_INITRAMFS_COMPRESSION_LZ4 is not set\n# CONFIG_RD_LZ4 is not set)" >> $(LINUX_DIR)/.config
endef
else
endif