aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-08 20:39:09 +0000
commit9cf9b81c7462e53033f34a656c6edeca073aacc2 (patch)
treeb99fad3fcba219f38492e031fb4a7ef4efc58b40
parent8602bad17ed40d67b82d85dd633aa53cb23e01a0 (diff)
downloadmaster-187ad058-9cf9b81c7462e53033f34a656c6edeca073aacc2.tar.gz
master-187ad058-9cf9b81c7462e53033f34a656c6edeca073aacc2.tar.bz2
master-187ad058-9cf9b81c7462e53033f34a656c6edeca073aacc2.zip
uhttpd: update to the latest version, adds support for redirect helper scripts
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47419 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/services/uhttpd/Makefile6
-rwxr-xr-xpackage/network/services/uhttpd/files/uhttpd.init4
2 files changed, 7 insertions, 3 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index d14e3a942e..f757696f64 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2015-10-20
+PKG_VERSION:=2015-11-08
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=618315bc0729c3064e06af2900a86211354f81c9
+PKG_SOURCE_VERSION:=fe01ef3f52adae9da38ef47926cd50974af5d6b7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=ISC
@@ -33,7 +33,7 @@ endef
define Package/uhttpd
$(Package/uhttpd/default)
- DEPENDS:=+libubox
+ DEPENDS:=+libubox +libblobmsg-json +libjson-script
endef
define Package/uhttpd/description
diff --git a/package/network/services/uhttpd/files/uhttpd.init b/package/network/services/uhttpd/files/uhttpd.init
index fcde52a564..d6ffc3b4c9 100755
--- a/package/network/services/uhttpd/files/uhttpd.init
+++ b/package/network/services/uhttpd/files/uhttpd.init
@@ -135,6 +135,10 @@ start_instance()
append_bool "$cfg" redirect_https "-q" 0
}
+ for file in /etc/uhttpd/*.json; do
+ [ -s "$file" ] && procd_append_param command -H "$file"
+ done
+
procd_close_instance
}