aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:42:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:42:00 +0000
commit9cb9bd7644e38f46646f56f32bd7c0f90b2e9c02 (patch)
tree953e5644723e3847f849d2b2451e79c054e6a144
parent9ecf9fd5ac359eb44164d43cddf5fe346e275ef5 (diff)
downloadmaster-187ad058-9cb9bd7644e38f46646f56f32bd7c0f90b2e9c02.tar.gz
master-187ad058-9cb9bd7644e38f46646f56f32bd7c0f90b2e9c02.tar.bz2
master-187ad058-9cb9bd7644e38f46646f56f32bd7c0f90b2e9c02.zip
oxnas: change file extension of u-boot+initramfs image
The *u-boot-initramfs* images are not ITB/FIT images but are rather supposed to be loaded to RAM and jumped-into. To avoid confusion, change the file extension from itb to bin. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45963 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/oxnas/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index 2660a9b125..de6c4db3ab 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -38,7 +38,7 @@ define Image/BuildKernel/Template
$(CP) $(KDIR)/fit-$(1)-initramfs.itb $(BIN_DIR)/$(IMG_PREFIX)-$(1)-fit-uImage-initramfs.itb
if [ -e "$(KDIR)/u-boot.bin" ]; then \
( dd if=$(KDIR)/u-boot.bin bs=128k conv=sync ; dd if=$(KDIR)/fit-$(1)-initramfs.itb bs=128k conv=sync ) \
- > $(BIN_DIR)/$(IMG_PREFIX)-$(1)-u-boot-initramfs.itb; \
+ > $(BIN_DIR)/$(IMG_PREFIX)-$(1)-u-boot-initramfs.bin; \
fi
endif