aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-14 08:38:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-14 08:38:35 +0000
commit939914d5e72990671ed74be6276dfdb46b0d3092 (patch)
tree41b25998f444532de271ebc167b0d7ded6305263
parent8c317f089a8f27f25a57932a4cbf3f0eebfa2b4b (diff)
downloadmaster-187ad058-939914d5e72990671ed74be6276dfdb46b0d3092.tar.gz
master-187ad058-939914d5e72990671ed74be6276dfdb46b0d3092.tar.bz2
master-187ad058-939914d5e72990671ed74be6276dfdb46b0d3092.zip
x86: disable rts/cts for serial console in grub - fixes net48xx boot issues
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44753 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/x86/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 59837180f1..9e40803aa7 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -32,7 +32,7 @@ GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
ifneq ($(GRUB_SERIAL),)
GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8
- GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
+ GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=off
GRUB_TERMINALS += serial
endif