aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-14 09:17:14 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-14 09:17:14 +0000
commit7e20c1e472fca99560006bc3d3b835d5854684a0 (patch)
treed9e8b77d90394ac3c91706e1f8feb6dbc300f46d
parent9fd4010f59b8ac97654be2eb2143c809bccbd3da (diff)
downloadmaster-187ad058-7e20c1e472fca99560006bc3d3b835d5854684a0.tar.gz
master-187ad058-7e20c1e472fca99560006bc3d3b835d5854684a0.tar.bz2
master-187ad058-7e20c1e472fca99560006bc3d3b835d5854684a0.zip
6in4: make local ip6addr optional
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33761 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh14
2 files changed, 9 insertions, 7 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index fdab290861..fcb0a7e756 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=11
+PKG_VERSION:=12
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 71bc68940c..651d7b97b7 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -17,7 +17,7 @@ proto_6in4_setup() {
local mtu ttl ipaddr peeraddr ip6addr tunnelid username password
json_get_vars mtu ttl ipaddr peeraddr ip6addr tunnelid username password
- [ -z "$ip6addr" -o -z "$peeraddr" ] && {
+ [ -z "$peeraddr" ] && {
proto_notify_error "$cfg" "MISSING_ADDRESS"
proto_block_restart "$cfg"
return
@@ -33,14 +33,16 @@ proto_6in4_setup() {
fi
}
- local local6="${ip6addr%%/*}"
- local mask6="${ip6addr##*/}"
- [[ "$local6" = "$mask6" ]] && mask6=
-
proto_init_update "$link" 1
- proto_add_ipv6_address "$local6" "$mask6"
proto_add_ipv6_route "::" 0
+ [ -n "$ip6addr" ] && {
+ local local6="${ip6addr%%/*}"
+ local mask6="${ip6addr##*/}"
+ [[ "$local6" = "$mask6" ]] && mask6=
+ proto_add_ipv6_address "$local6" "$mask6"
+ }
+
proto_add_tunnel
json_add_string mode sit
json_add_int mtu "${mtu:-1280}"