aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-08-23 17:07:26 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-08-23 17:07:26 +0000
commit75a5ef5f93d8c7ca517dbe4bfdea06728d9e2eef (patch)
tree9215cb6af428527859c082d2561012223d8603ad
parent45c4c5845014750222d532fb756c37e088bd44a1 (diff)
downloadmaster-187ad058-75a5ef5f93d8c7ca517dbe4bfdea06728d9e2eef.tar.gz
master-187ad058-75a5ef5f93d8c7ca517dbe4bfdea06728d9e2eef.tar.bz2
master-187ad058-75a5ef5f93d8c7ca517dbe4bfdea06728d9e2eef.zip
ramips: use correct parameters in the Seama template
Fixes DIR-645 image generation errors: bash: line 0: [: wrgn39_dlob.hans_dir645: integer expression expected ... bash: wrgn39_dlob.hans_dir645 - 64: syntax error: invalid arithmetic operator (error token is ".hans_dir645 - 64") make[4]: *** [install] Error 1 Signed-off-by: Michael Lee <igvtee@gmail.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37828 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ramips/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 18f0fe5e0e..ba7f6608a5 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -156,9 +156,9 @@ BuildFirmware/Edimax/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
# build Seama header images
define BuildFirmware/Seama/squashfs
- $(call BuildFirmware/OF,$(1),$(2),$(3),$(4))
+ $(call BuildFirmware/OF,$(1),$(2),$(3),$(5))
cat $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/root.$(1) > $(KDIR)/img_$(2).$(1).tmp
- if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(4) - 64)) ]; then \
+ if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(5) - 64)) ]; then \
echo "Warning: $(KDIR)/img_$(2).$(1).tmp is too big" >&2; \
else \
dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=64k conv=sync; \