aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-05-18 17:29:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-05-18 17:29:39 +0000
commit72192c48c5f7139bbdaf4ee21352dfe90f4cfa57 (patch)
tree5bd7d3586a123822d0e9c8e9bed41e52083ac498
parent07131c043cef2983b9cbf161abc752209220d9a7 (diff)
downloadmaster-187ad058-72192c48c5f7139bbdaf4ee21352dfe90f4cfa57.tar.gz
master-187ad058-72192c48c5f7139bbdaf4ee21352dfe90f4cfa57.tar.bz2
master-187ad058-72192c48c5f7139bbdaf4ee21352dfe90f4cfa57.zip
bcm963xx: fix load address / kernel entry
Current kernels have the same kernel entry as load address, so just set them like this. Also, the BCM963xx uses 0x80010000 as its load address, so use this too. Signed-off-by: Axel Gembe <ago@bastart.eu.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11169 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm63xx/image/Makefile4
-rw-r--r--target/linux/brcm63xx/image/lzma-loader/src/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 16c57cae4f..227dbd7a54 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -7,8 +7,8 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-LOADADDR = 0x8108c8f4 # RAM start + 16M
-KERNEL_ENTRY = 0x80100000 # Default kernel entry in arch/mips/Makefile
+LOADADDR = 0x80010000 # RAM start + 16M
+KERNEL_ENTRY = $(LOADADDR) # Newer kernels add a jmp to the kernel_entry at the start of the binary
RAMSIZE = 0x01000000 # 64MB
LOADER_MAKEOPTS= \
diff --git a/target/linux/brcm63xx/image/lzma-loader/src/Makefile b/target/linux/brcm63xx/image/lzma-loader/src/Makefile
index 85a864674b..83e2c52386 100644
--- a/target/linux/brcm63xx/image/lzma-loader/src/Makefile
+++ b/target/linux/brcm63xx/image/lzma-loader/src/Makefile
@@ -17,7 +17,7 @@
# Cleaned up, modified for lzma support, removed from kernel
#
-TEXT_START := 0x80001000
+TEXT_START := 0x80010000
BZ_TEXT_START := 0x80300000
OBJCOPY := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S