aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-18 10:19:28 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-18 10:19:28 +0000
commit6edc1cb19f9b296fed6f740de4b29db1df44f31f (patch)
tree4855237e8a369f9e9422cf3a96a6fa163a4aa489
parent470f25630f56358f6f292e361b15b745f8d5dac0 (diff)
downloadmaster-187ad058-6edc1cb19f9b296fed6f740de4b29db1df44f31f.tar.gz
master-187ad058-6edc1cb19f9b296fed6f740de4b29db1df44f31f.tar.bz2
master-187ad058-6edc1cb19f9b296fed6f740de4b29db1df44f31f.zip
ar71xx/image: remove duplicated rootfs in new tplink initramfs images
The new building code included the rootfs twice when building tplink initramfs images. To make it more readable move initramfs into an own build step Build/mktplinkfw-initramfs. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45491 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4819ab983b..49c3ca04b2 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -56,10 +56,20 @@ define Build/mktplinkfw
-k $(word 1,$^) \
-r $@ \
-o $@.new \
+ -j -X 0x40000 \
-a $(call rootfs_align,$(FILESYSTEM)) \
- $(if $(findstring sysupgrade,$1),-j -X 0x40000 -s) \
- $(if $(findstring factory,$1),-j -X 0x40000) \
- $(if $(findstring initramfs,$1),-s -c)
+ $(if $(findstring sysupgrade,$1),-s)
+ @mv $@.new $@
+endef
+
+# -c combined image
+define Build/mktplinkfw-initramfs
+ $(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+ -k $@ \
+ -o $@.new \
+ -s \
+ -c
@mv $@.new $@
endef
@@ -138,7 +148,7 @@ TARGET_DEVICES += wndr3700 wndr3700v2 wndr3800 wndr3800ch wndrmac wndrmacv2
define Device/tplink
TPLINK_HWREV := 0x1
KERNEL := kernel-bin | patch-cmdline | lzma
- KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | mktplinkfw initramfs
+ KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | mktplinkfw-initramfs
IMAGES := sysupgrade.bin factory.bin
IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade
IMAGE/factory.bin := append-rootfs | mktplinkfw factory