aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-20 12:17:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-20 12:17:43 +0000
commit68f74bd0d7ab7ed1acb46ae938b7ffa9dcc05125 (patch)
tree6bc023b43505ce9cb566af8877cb2d71a624387e
parenta36d8dba576f91488f5649e18e1d6d9c21f421b1 (diff)
downloadmaster-187ad058-68f74bd0d7ab7ed1acb46ae938b7ffa9dcc05125.tar.gz
master-187ad058-68f74bd0d7ab7ed1acb46ae938b7ffa9dcc05125.tar.bz2
master-187ad058-68f74bd0d7ab7ed1acb46ae938b7ffa9dcc05125.zip
ar71xx/image: provide lzma compressed elf kernel image
This will be used on the RB4xx/RB7xx/RB2011 boards. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34272 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index dbda865ec6..f4d66b97cc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -192,6 +192,7 @@ define Image/BuildKernel
dd if=$(KDIR)/vmlinux.bin.gz of=$(VMLINUX).gz bs=65536 conv=sync
$(call MkuImage,gzip,,$(KDIR)/vmlinux.bin.gz,$(UIMAGE)-gzip.bin)
$(call MkuImage,lzma,,$(KDIR)/vmlinux.bin.lzma,$(UIMAGE)-lzma.bin)
+ cp $(KDIR)/loader-generic.elf $(VMLINUX)-lzma.elf
-mkdir -p $(KDIR_TMP)
$(call Image/Build/Initramfs)
endef
@@ -945,6 +946,7 @@ endef
define Image/Prepare
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(call CompressLzma,$(KDIR)/vmlinux,$(KDIR)/vmlinux.bin.lzma)
+ $(call Image/BuildLoader,generic,elf)
$(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(PROFILE)),loader)
endef