aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-22 15:11:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-22 15:11:27 +0000
commit6374e776523f2f3c5e7a484f60890527e5ffceab (patch)
tree83f7a478a0e8f2756904e1c2c91f868569f1dd3a
parent0940db5e2e3b0c227ee79200b99fe31db0ebc452 (diff)
downloadmaster-187ad058-6374e776523f2f3c5e7a484f60890527e5ffceab.tar.gz
master-187ad058-6374e776523f2f3c5e7a484f60890527e5ffceab.tar.bz2
master-187ad058-6374e776523f2f3c5e7a484f60890527e5ffceab.zip
fstools: update to the latest version, makes interrupted first boot more reliable
Use xattr to store the filesystem initialization state of the overlay. As long as the filesystem is not marked as initialized yet (happens in /etc/init.d/done), all overlay data (except for sysupgrade.tgz) will be discarded before the system is allowed to boot Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44942 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xpackage/base-files/files/etc/init.d/done2
-rw-r--r--package/system/fstools/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/files/etc/init.d/done b/package/base-files/files/etc/init.d/done
index ed75e4022f..374353a23c 100755
--- a/package/base-files/files/etc/init.d/done
+++ b/package/base-files/files/etc/init.d/done
@@ -3,7 +3,7 @@
START=95
boot() {
- [ -d /tmp/root ] && mount_root done
+ mount_root done
rm -f /sysupgrade.tgz
# process user commands
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 9040fd9417..ad3206943a 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fstools
-PKG_VERSION:=2015-03-12
+PKG_VERSION:=2015-03-22
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/fstools.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=0b99adb02f2eb822fbfc4efcb8ebf5fecbd74974
+PKG_SOURCE_VERSION:=eb9181b33bdda2e1ce81094d77913f7b68e26156
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
PKG_CHECK_FORMAT_SECURITY:=0