aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2015-09-08 17:44:17 +0000
committerSteven Barth <steven@midlink.org>2015-09-08 17:44:17 +0000
commit5ff4b3ea4e1af3efedbd20277769bbc2818c3299 (patch)
tree37c2c662e2ca09a94532aee2698e7cf127bd754b
parent9076136aba1429a57db1db34b6d2093e3815ee54 (diff)
downloadmaster-187ad058-5ff4b3ea4e1af3efedbd20277769bbc2818c3299.tar.gz
master-187ad058-5ff4b3ea4e1af3efedbd20277769bbc2818c3299.tar.bz2
master-187ad058-5ff4b3ea4e1af3efedbd20277769bbc2818c3299.zip
iproute2: improve ip-full coexistence, remove rt_table
Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46831 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/network/utils/iproute2/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 7b55f695e8..cc73c1318b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iproute2
PKG_VERSION:=4.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
@@ -39,10 +39,6 @@ endef
Package/ip-full=$(call Package/iproute2/Default,full,Full)
-define Package/ip/conffiles
-/etc/iproute2/rt_tables
-endef
-
define Package/ip-$(BUILD_VARIANT)/conffiles
$(Package/ip/conffiles)
endef
@@ -112,13 +108,12 @@ endef
define Package/ip/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_DIR) $(1)/etc/iproute2
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
endef
-define Package/ip-$(BUILD_VARIANT)/install
- $(Package/ip/install)
+define Package/ip-full/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/bin/
endef
define Package/tc/install