aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-16 11:13:47 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-16 11:13:47 +0000
commit5713daa1e7082429ab25c5c9e233854b5a7739d4 (patch)
treefe6fca9399f4e41f3cfc6a444d097170919f9a8a
parentaf855c685f785186630cea4ea0e30a601e9a1d82 (diff)
downloadmaster-187ad058-5713daa1e7082429ab25c5c9e233854b5a7739d4.tar.gz
master-187ad058-5713daa1e7082429ab25c5c9e233854b5a7739d4.tar.bz2
master-187ad058-5713daa1e7082429ab25c5c9e233854b5a7739d4.zip
brcm63xx: make use of the new BuildDTB command
Now that we have a BuildDTB command, make use of it instead of calling dtc directly. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46390 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 63cd90a17d..98d145276c 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -198,7 +198,7 @@ endef
define Image/PrepareCFELzmaKernelDTB
# compile the dts (the dtb will be later reused for the lzma loader)
- $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(DTS_DIR)/$(1).dtb ../dts/$(1).dts
+ $(call Image/BuildDTB,../dts/$(1).dts,$(DTS_DIR)/$(1).dtb)
cat $(KDIR)/vmlinux $(DTS_DIR)/$(1).dtb > $(KDIR)/vmlinux-$(1)
$(call Image/PrepareCFELzmaKernel,-$(1))
rm -f $(KDIR)/vmlinux-$(1)