aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-05-19 23:02:14 +0000
committerMike Baker <mbm@openwrt.org>2006-05-19 23:02:14 +0000
commit4f04e2e72f8d4b96d1b225202d04d83a9baae7c0 (patch)
treea0285c2ef011f3e8dce29372af61c786334d2567
parent6ae20c689a562e133596a018fa65b771fde67c5b (diff)
downloadmaster-187ad058-4f04e2e72f8d4b96d1b225202d04d83a9baae7c0.tar.gz
master-187ad058-4f04e2e72f8d4b96d1b225202d04d83a9baae7c0.tar.bz2
master-187ad058-4f04e2e72f8d4b96d1b225202d04d83a9baae7c0.zip
fix .pkginfo line to allow the use of $(SOURCE)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3802 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Makefile8
-rw-r--r--package/busybox/Makefile9
2 files changed, 9 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 9b9d1c955e..9b341f1241 100644
--- a/Makefile
+++ b/Makefile
@@ -41,11 +41,11 @@ export OPENWRTVERSION
all:
.pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
@echo Collecting package info...
- @-for makefile in package/*/Makefile; do \
- echo Source-Makefile: $$makefile; \
- $(MAKE) --no-print-dir DUMP=1 -f $$makefile 2>&- || true; \
+ @-for dir in package/*/; do \
+ echo Source-Makefile: $${dir}Makefile; \
+ $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
done > $@
endif
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index ff23ee7dd8..cc36301f52 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -23,10 +23,11 @@ TITLE:=Core utilities for embedded Linux
DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
It slices, it dices, it makes Julian Fries.
URL:=http://busybox.net/
-CONFIG:=menu "Configuration" \\\
- depends on PACKAGE_busybox \\\
-source "package/busybox/config/Config.in" \\\
-endmenu
+CONFIG:=\\\
+ menu "Configuration" \\\
+ depends on PACKAGE_busybox \\\
+ source "$(SOURCE)/config/Config.in" \\\
+ endmenu
endef
define Build/Configure