aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-07 09:38:41 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-07 09:38:41 +0000
commit4ec9772476fceb593b8c05949704fe0fc13efca2 (patch)
tree8118dbaefccc46ad0cb028f5e8ae1c3675fb187f
parent3a7d040e44bd18900a2efbdd85e2daaf67e38730 (diff)
downloadmaster-187ad058-4ec9772476fceb593b8c05949704fe0fc13efca2.tar.gz
master-187ad058-4ec9772476fceb593b8c05949704fe0fc13efca2.tar.bz2
master-187ad058-4ec9772476fceb593b8c05949704fe0fc13efca2.zip
Also add eeprom 93cx6 to generic-2.6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8372 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/generic-2.6/patches/000-eeprom_93cx6.patch358
-rw-r--r--target/linux/generic-2.6/patches/001-eeprom_93cx6.patch46
-rw-r--r--target/linux/generic-2.6/patches/002-eeprom_93cx6.patch36
3 files changed, 440 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches/000-eeprom_93cx6.patch b/target/linux/generic-2.6/patches/000-eeprom_93cx6.patch
new file mode 100644
index 0000000000..ff23846b47
--- /dev/null
+++ b/target/linux/generic-2.6/patches/000-eeprom_93cx6.patch
@@ -0,0 +1,358 @@
+From: Ivo van Doorn <ivdoorn@gmail.com>
+Date: Fri, 11 May 2007 19:59:40 +0000 (-0400)
+Subject: [PATCH] Add 93cx6 eeprom library
+X-Git-Tag: v2.6.23-rc1~1201^2~74
+X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=9467d64b0e88763914c01f71ddf591b166c4f526
+
+[PATCH] Add 93cx6 eeprom library
+
+This patch adds a library for reading from 93cx6 eeproms.
+
+Signed-off-by: Michael Wu <flamingice@sourmilk.net>
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+
+diff --git a/drivers/misc/Kconfig b/drivers/misc/Kconfig
+index 616eee9..bd601ef 100644
+--- a/drivers/misc/Kconfig
++++ b/drivers/misc/Kconfig
+@@ -34,6 +34,11 @@ config PHANTOM
+ If you choose to build module, its name will be phantom. If unsure,
+ say N here.
+
++config EEPROM_93CX6
++ tristate "EEPROM 93CX6 support"
++ ---help---
++ This is a driver for the EEPROM chipsets 93c46 and 93c66.
++ The driver supports both read as well as write commands.
+
+ If unsure, say N.
+
+@@ -187,5 +192,4 @@ config THINKPAD_ACPI_BAY
+
+ If you are not sure, say Y here.
+
+-
+ endmenu
+diff --git a/drivers/misc/Makefile b/drivers/misc/Makefile
+index 8abbf2f..b5ce0e3 100644
+--- a/drivers/misc/Makefile
++++ b/drivers/misc/Makefile
+@@ -14,3 +14,4 @@ obj-$(CONFIG_PHANTOM) += phantom.o
+ obj-$(CONFIG_SGI_IOC4) += ioc4.o
+ obj-$(CONFIG_SONY_LAPTOP) += sony-laptop.o
+ obj-$(CONFIG_THINKPAD_ACPI) += thinkpad_acpi.o
++obj-$(CONFIG_EEPROM_93CX6) += eeprom_93cx6.o
+diff --git a/drivers/misc/eeprom_93cx6.c b/drivers/misc/eeprom_93cx6.c
+new file mode 100644
+index 0000000..bfcb434
+--- /dev/null
++++ b/drivers/misc/eeprom_93cx6.c
+@@ -0,0 +1,229 @@
++/*
++ Copyright (C) 2004 - 2006 rt2x00 SourceForge Project
++ <http://rt2x00.serialmonkey.com>
++
++ This program is free software; you can redistribute it and/or modify
++ it under the terms of the GNU General Public License as published by
++ the Free Software Foundation; either version 2 of the License, or
++ (at your option) any later version.
++
++ This program is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ GNU General Public License for more details.
++
++ You should have received a copy of the GNU General Public License
++ along with this program; if not, write to the
++ Free Software Foundation, Inc.,
++ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
++ */
++
++/*
++ Module: eeprom_93cx6
++ Abstract: EEPROM reader routines for 93cx6 chipsets.
++ Supported chipsets: 93c46 & 93c66.
++ */
++
++#include <linux/kernel.h>
++#include <linux/module.h>
++#include <linux/version.h>
++#include <linux/delay.h>
++#include <linux/eeprom_93cx6.h>
++
++MODULE_AUTHOR("http://rt2x00.serialmonkey.com");
++MODULE_VERSION("1.0");
++MODULE_DESCRIPTION("EEPROM 93cx6 chip driver");
++MODULE_LICENSE("GPL");
++
++static inline void eeprom_93cx6_pulse_high(struct eeprom_93cx6 *eeprom)
++{
++ eeprom->reg_data_clock = 1;
++ eeprom->register_write(eeprom);
++ udelay(1);
++}
++
++static inline void eeprom_93cx6_pulse_low(struct eeprom_93cx6 *eeprom)
++{
++ eeprom->reg_data_clock = 0;
++ eeprom->register_write(eeprom);
++ udelay(1);
++}
++
++static void eeprom_93cx6_startup(struct eeprom_93cx6 *eeprom)
++{
++ /*
++ * Clear all flags, and enable chip select.
++ */
++ eeprom->register_read(eeprom);
++ eeprom->reg_data_in = 0;
++ eeprom->reg_data_out = 0;
++ eeprom->reg_data_clock = 0;
++ eeprom->reg_chip_select = 1;
++ eeprom->register_write(eeprom);
++
++ /*
++ * kick a pulse.
++ */
++ eeprom_93cx6_pulse_high(eeprom);
++ eeprom_93cx6_pulse_low(eeprom);
++}
++
++static void eeprom_93cx6_cleanup(struct eeprom_93cx6 *eeprom)
++{
++ /*
++ * Clear chip_select and data_in flags.
++ */
++ eeprom->register_read(eeprom);
++ eeprom->reg_data_in = 0;
++ eeprom->reg_chip_select = 0;
++ eeprom->register_write(eeprom);
++
++ /*
++ * kick a pulse.
++ */
++ eeprom_93cx6_pulse_high(eeprom);
++ eeprom_93cx6_pulse_low(eeprom);
++}
++
++static void eeprom_93cx6_write_bits(struct eeprom_93cx6 *eeprom,
++ const u16 data, const u16 count)
++{
++ unsigned int i;
++
++ eeprom->register_read(eeprom);
++
++ /*
++ * Clear data flags.
++ */
++ eeprom->reg_data_in = 0;
++ eeprom->reg_data_out = 0;
++
++ /*
++ * Start writing all bits.
++ */
++ for (i = count; i > 0; i--) {
++ /*
++ * Check if this bit needs to be set.
++ */
++ eeprom->reg_data_in = !!(data & (1 << (i - 1)));
++
++ /*
++ * Write the bit to the eeprom register.
++ */
++ eeprom->register_write(eeprom);
++
++ /*
++ * Kick a pulse.
++ */
++ eeprom_93cx6_pulse_high(eeprom);
++ eeprom_93cx6_pulse_low(eeprom);
++ }
++
++ eeprom->reg_data_in = 0;
++ eeprom->register_write(eeprom);
++}
++
++static void eeprom_93cx6_read_bits(struct eeprom_93cx6 *eeprom,
++ u16 *data, const u16 count)
++{
++ unsigned int i;
++ u16 buf = 0;
++
++ eeprom->register_read(eeprom);
++
++ /*
++ * Clear data flags.
++ */
++ eeprom->reg_data_in = 0;
++ eeprom->reg_data_out = 0;
++
++ /*
++ * Start reading all bits.
++ */
++ for (i = count; i > 0; i--) {
++ eeprom_93cx6_pulse_high(eeprom);
++
++ eeprom->register_read(eeprom);
++
++ /*
++ * Clear data_in flag.
++ */
++ eeprom->reg_data_in = 0;
++
++ /*
++ * Read if the bit has been set.
++ */
++ if (eeprom->reg_data_out)
++ buf |= (1 << (i - 1));
++
++ eeprom_93cx6_pulse_low(eeprom);
++ }
++
++ *data = buf;
++}
++
++/**
++ * eeprom_93cx6_read - Read multiple words from eeprom
++ * @eeprom: Pointer to eeprom structure
++ * @word: Word index from where we should start reading
++ * @data: target pointer where the information will have to be stored
++ *
++ * This function will read the eeprom data as host-endian word
++ * into the given data pointer.
++ */
++void eeprom_93cx6_read(struct eeprom_93cx6 *eeprom, const u8 word,
++ u16 *data)
++{
++ u16 command;
++
++ /*
++ * Initialize the eeprom register
++ */
++ eeprom_93cx6_startup(eeprom);
++
++ /*
++ * Select the read opcode and the word to be read.
++ */
++ command = (PCI_EEPROM_READ_OPCODE << eeprom->width) | word;
++ eeprom_93cx6_write_bits(eeprom, command,
++ PCI_EEPROM_WIDTH_OPCODE + eeprom->width);
++
++ /*
++ * Read the requested 16 bits.
++ */
++ eeprom_93cx6_read_bits(eeprom, data, 16);
++
++ /*
++ * Cleanup eeprom register.
++ */
++ eeprom_93cx6_cleanup(eeprom);
++}
++EXPORT_SYMBOL_GPL(eeprom_93cx6_read);
++
++/**
++ * eeprom_93cx6_multiread - Read multiple words from eeprom
++ * @eeprom: Pointer to eeprom structure
++ * @word: Word index from where we should start reading
++ * @data: target pointer where the information will have to be stored
++ * @words: Number of words that should be read.
++ *
++ * This function will read all requested words from the eeprom,
++ * this is done by calling eeprom_93cx6_read() multiple times.
++ * But with the additional change that while the eeprom_93cx6_read
++ * will return host ordered bytes, this method will return little
++ * endian words.
++ */
++void eeprom_93cx6_multiread(struct eeprom_93cx6 *eeprom, const u8 word,
++ __le16 *data, const u16 words)
++{
++ unsigned int i;
++ u16 tmp;
++
++ for (i = 0; i < words; i++) {
++ tmp = 0;
++ eeprom_93cx6_read(eeprom, word + i, &tmp);
++ data[i] = cpu_to_le16(tmp);
++ }
++}
++EXPORT_SYMBOL_GPL(eeprom_93cx6_multiread);
++
+diff --git a/include/linux/eeprom_93cx6.h b/include/linux/eeprom_93cx6.h
+new file mode 100644
+index 0000000..d774b77
+--- /dev/null
++++ b/include/linux/eeprom_93cx6.h
+@@ -0,0 +1,72 @@
++/*
++ Copyright (C) 2004 - 2006 rt2x00 SourceForge Project
++ <http://rt2x00.serialmonkey.com>
++
++ This program is free software; you can redistribute it and/or modify
++ it under the terms of the GNU General Public License as published by
++ the Free Software Foundation; either version 2 of the License, or
++ (at your option) any later version.
++
++ This program is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ GNU General Public License for more details.
++
++ You should have received a copy of the GNU General Public License
++ along with this program; if not, write to the
++ Free Software Foundation, Inc.,
++ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
++ */
++
++/*
++ Module: eeprom_93cx6
++ Abstract: EEPROM reader datastructures for 93cx6 chipsets.
++ Supported chipsets: 93c46 & 93c66.
++ */
++
++/*
++ * EEPROM operation defines.
++ */
++#define PCI_EEPROM_WIDTH_93C46 6
++#define PCI_EEPROM_WIDTH_93C66 8
++#define PCI_EEPROM_WIDTH_OPCODE 3
++#define PCI_EEPROM_WRITE_OPCODE 0x05
++#define PCI_EEPROM_READ_OPCODE 0x06
++#define PCI_EEPROM_EWDS_OPCODE 0x10
++#define PCI_EEPROM_EWEN_OPCODE 0x13
++
++/**
++ * struct eeprom_93cx6 - control structure for setting the commands
++ * for reading the eeprom data.
++ * @data: private pointer for the driver.
++ * @register_read(struct eeprom_93cx6 *eeprom): handler to
++ * read the eeprom register, this function should set all reg_* fields.
++ * @register_write(struct eeprom_93cx6 *eeprom): handler to
++ * write to the eeprom register by using all reg_* fields.
++ * @width: eeprom width, should be one of the PCI_EEPROM_WIDTH_* defines
++ * @reg_data_in: register field to indicate data input
++ * @reg_data_out: register field to indicate data output
++ * @reg_data_clock: register field to set the data clock
++ * @reg_chip_select: register field to set the chip select
++ *
++ * This structure is used for the communication between the driver
++ * and the eeprom_93cx6 handlers for reading the eeprom.
++ */
++struct eeprom_93cx6 {
++ void *data;
++
++ void (*register_read)(struct eeprom_93cx6 *eeprom);
++ void (*register_write)(struct eeprom_93cx6 *eeprom);
++
++ int width;
++
++ char reg_data_in;
++ char reg_data_out;
++ char reg_data_clock;
++ char reg_chip_select;
++};
++
++extern void eeprom_93cx6_read(struct eeprom_93cx6 *eeprom,
++ const u8 word, u16 *data);
++extern void eeprom_93cx6_multiread(struct eeprom_93cx6 *eeprom,
++ const u8 word, __le16 *data, const u16 words);
diff --git a/target/linux/generic-2.6/patches/001-eeprom_93cx6.patch b/target/linux/generic-2.6/patches/001-eeprom_93cx6.patch
new file mode 100644
index 0000000000..9bc19fb49b
--- /dev/null
+++ b/target/linux/generic-2.6/patches/001-eeprom_93cx6.patch
@@ -0,0 +1,46 @@
+From: Ivo van Doorn <ivdoorn@gmail.com>
+Date: Mon, 14 May 2007 21:06:01 +0000 (+0200)
+Subject: [PATCH] eeprom_93cx6: Add comment for 1us delay after pulse
+X-Git-Tag: v2.6.23-rc1~1201^2~73
+X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=4b914dc0493edff19ff698a18198a173a14ba9d2
+
+[PATCH] eeprom_93cx6: Add comment for 1us delay after pulse
+
+This will add a comment for the 1us delay which is taken
+after the pulse has been switched. The 1us delay is based
+on the specifications so that should be made clear.
+
+Signed-off-by: Ivo van Doorn <IvDoorn@gmail.com>
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+
+diff --git a/drivers/misc/eeprom_93cx6.c b/drivers/misc/eeprom_93cx6.c
+index bfcb434..0d6d742 100644
+--- a/drivers/misc/eeprom_93cx6.c
++++ b/drivers/misc/eeprom_93cx6.c
+@@ -39,6 +39,12 @@ static inline void eeprom_93cx6_pulse_high(struct eeprom_93cx6 *eeprom)
+ {
+ eeprom->reg_data_clock = 1;
+ eeprom->register_write(eeprom);
++
++ /*
++ * Add a short delay for the pulse to work.
++ * According to the specifications the minimal time
++ * should be 450ns so a 1us delay is sufficient.
++ */
+ udelay(1);
+ }
+
+@@ -46,6 +52,12 @@ static inline void eeprom_93cx6_pulse_low(struct eeprom_93cx6 *eeprom)
+ {
+ eeprom->reg_data_clock = 0;
+ eeprom->register_write(eeprom);
++
++ /*
++ * Add a short delay for the pulse to work.
++ * According to the specifications the minimal time
++ * should be 450ns so a 1us delay is sufficient.
++ */
+ udelay(1);
+ }
+
diff --git a/target/linux/generic-2.6/patches/002-eeprom_93cx6.patch b/target/linux/generic-2.6/patches/002-eeprom_93cx6.patch
new file mode 100644
index 0000000000..7f2b125542
--- /dev/null
+++ b/target/linux/generic-2.6/patches/002-eeprom_93cx6.patch
@@ -0,0 +1,36 @@
+From: John W. Linville <linville@tuxdriver.com>
+Date: Tue, 12 Jun 2007 01:37:46 +0000 (-0400)
+Subject: [PATCH] eeprom_93cx6: shorten pulse timing to match spec
+X-Git-Tag: v2.6.23-rc1~1201^2~71
+X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Ftorvalds%2Flinux-2.6.git;a=commitdiff_plain;h=7e9400f178d291b2208c4ed9aac0f425c1364000
+
+[PATCH] eeprom_93cx6: shorten pulse timing to match spec
+
+93cx6 datasheet available here:
+
+ http://ww1.microchip.com/downloads/en/DeviceDoc/21749F.pdf
+
+Figure 1-1 and Table 1-2 on pages 4-5 indicate that both Clock High
+Time and Clock Low Time have largest minimum times of 450ns.
+
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+---
+
+diff --git a/drivers/misc/eeprom_93cx6.c b/drivers/misc/eeprom_93cx6.c
+index 0d6d742..ac515b0 100644
+--- a/drivers/misc/eeprom_93cx6.c
++++ b/drivers/misc/eeprom_93cx6.c
+@@ -42,10 +42,10 @@ static inline void eeprom_93cx6_pulse_high(struct eeprom_93cx6 *eeprom)
+
+ /*
+ * Add a short delay for the pulse to work.
+- * According to the specifications the minimal time
+- * should be 450ns so a 1us delay is sufficient.
++ * According to the specifications the "maximum minimum"
++ * time should be 450ns.
+ */
+- udelay(1);
++ ndelay(450);
+ }
+
+ static inline void eeprom_93cx6_pulse_low(struct eeprom_93cx6 *eeprom)