aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-01-29 12:19:31 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-01-29 12:19:31 +0000
commit4168e195e2692489ac1f137613e68758bf5e0515 (patch)
tree735acc848792868f9e45f4a6a921c5f92db629ba
parent625be51c75e38acc4cb2a45e578609c88f16c51f (diff)
downloadmaster-187ad058-4168e195e2692489ac1f137613e68758bf5e0515.tar.gz
master-187ad058-4168e195e2692489ac1f137613e68758bf5e0515.tar.bz2
master-187ad058-4168e195e2692489ac1f137613e68758bf5e0515.zip
update to 2.6.32.7
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19379 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/Makefile4
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch2
-rw-r--r--target/linux/omap35xx/Makefile2
-rw-r--r--target/linux/xburst/Makefile2
5 files changed, 7 insertions, 7 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 4a0798fcf6..e23289f3fc 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -22,8 +22,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.31.12)
LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
endif
-ifeq ($(LINUX_VERSION),2.6.32.6)
- LINUX_KERNEL_MD5SUM:=5ad2ea7b6aed2d857dd9bb5ae03588e4
+ifeq ($(LINUX_VERSION),2.6.32.7)
+ LINUX_KERNEL_MD5SUM:=d59aca06609cedabe4d6d161d9f11113
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 4a153e8374..9340556525 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
FEATURES:=squashfs jffs2 tgz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-LINUX_VERSION:=2.6.32.6
+LINUX_VERSION:=2.6.32.7
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch b/target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch
index f59eac3203..1c60dbc504 100644
--- a/target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch
+++ b/target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch
@@ -68,7 +68,7 @@
* macro override instead of weak attribute alias, to workaround
--- a/kernel/sched.c
+++ b/kernel/sched.c
-@@ -6091,6 +6091,7 @@ int can_nice(const struct task_struct *p
+@@ -6093,6 +6093,7 @@ int can_nice(const struct task_struct *p
return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
capable(CAP_SYS_NICE));
}
diff --git a/target/linux/omap35xx/Makefile b/target/linux/omap35xx/Makefile
index b524b56f72..cc95fe68ef 100644
--- a/target/linux/omap35xx/Makefile
+++ b/target/linux/omap35xx/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP35xx
FEATURES:=broken
SUBTARGETS=generic
-LINUX_VERSION:=2.6.32.6
+LINUX_VERSION:=2.6.32.7
KERNELNAME:="uImage"
DEVICE_TYPE=developerboard
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 67de2cc6d9..51fe564f00 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -11,7 +11,7 @@ BOARD:=xburst
BOARDNAME:=XBurst JZ47x0
FEATURES:=jffs2 tgz ubifs
-LINUX_VERSION:=2.6.32.6
+LINUX_VERSION:=2.6.32.7
DEVICE_TYPE=other