aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-08-30 10:30:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-08-30 10:30:14 +0000
commit3e94d11f23218fa942819621e557b89bd11aea4c (patch)
treea9d5576680e81e0ad400bdbcf06155a3bae1b42b
parentb5203a34fc2914fcede2a5795ec62682aa4a2bd5 (diff)
downloadmaster-187ad058-3e94d11f23218fa942819621e557b89bd11aea4c.tar.gz
master-187ad058-3e94d11f23218fa942819621e557b89bd11aea4c.tar.bz2
master-187ad058-3e94d11f23218fa942819621e557b89bd11aea4c.zip
use an if block on the whole configure command
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4717 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/package.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/package.mk b/include/package.mk
index 8d90509305..9a947f3582 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -263,7 +263,7 @@ endef
define Build/Configure/Default
@(cd $(PKG_BUILD_DIR)/$(3); \
- [ \! -x configure ] || \
+ if [ -x configure ]; then \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -287,6 +287,7 @@ define Build/Configure/Default
--infodir=/usr/info \
$(DISABLE_NLS) \
$(1); \
+ fi; \
)
endef