aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
commit39968194002433a9e0313e4189585f31abeacaf7 (patch)
tree9c245e5990a829b3c87a13a609cec2142fd3439b
parente97c3c74fb20530196e220a3670a21c3c7c0c049 (diff)
downloadmaster-187ad058-39968194002433a9e0313e4189585f31abeacaf7.tar.gz
master-187ad058-39968194002433a9e0313e4189585f31abeacaf7.tar.bz2
master-187ad058-39968194002433a9e0313e4189585f31abeacaf7.zip
another optimization
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5507 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Makefile7
-rw-r--r--include/verbose.mk2
2 files changed, 7 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index d6b1b7d618..62a0338746 100644
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,15 @@ SHELL:=/usr/bin/env bash
export LC_ALL=C
export LANG=C
export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
ifeq ($(KBUILD_VERBOSE),99)
MAKE:=3>/dev/null $(MAKE)
endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+ IS_TTY=1
+ export IS_TTY
+endif
+
+include $(TOPDIR)/include/verbose.mk
OPENWRTVERSION:=$(RELEASE)
ifneq ($(VERSION),)
diff --git a/include/verbose.mk b/include/verbose.mk
index 34568a31f8..b4242f212a 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -18,7 +18,7 @@ ifeq ("$(origin V)", "command line")
KBUILD_VERBOSE:=$(V)
endif
-ifneq ($(shell tty -s <&3 || echo x),x)
+ifeq ($(IS_TTY),1)
_Y:="\\33[33m"# yellow
_N:="\\33[m"# normal
endif