aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2014-01-31 15:53:53 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2014-01-31 15:53:53 +0000
commit34c49dcc5ee400efe1a4ebcee8ac07a2acce8256 (patch)
treed4fee08614e634ebe4a4f451990bc2911b6574d7
parentce73f9f14582d13aca15d1572ec229de802e8dea (diff)
downloadmaster-187ad058-34c49dcc5ee400efe1a4ebcee8ac07a2acce8256.tar.gz
master-187ad058-34c49dcc5ee400efe1a4ebcee8ac07a2acce8256.tar.bz2
master-187ad058-34c49dcc5ee400efe1a4ebcee8ac07a2acce8256.zip
sunxi: boot changes
- Added uEnv.txt to facilitate automatic boot. - Cosmetic fix in u-boot Makefile - Don't force command line arguments Signed-off-by: Zalan Blenessy <zalan.blenessy@gmail.com> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39438 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/boot/uboot-sunxi/Makefile6
-rw-r--r--package/boot/uboot-sunxi/uEnv.txt5
-rw-r--r--target/linux/sunxi/config-3.122
3 files changed, 10 insertions, 3 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index cedf2c454b..796a6045cc 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -98,9 +98,11 @@ define Package/uboot/install/default
$(CP) $(PKG_BUILD_DIR)/u-boot.bin \
$(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot.bin
$(CP) $(PKG_BUILD_DIR)/spl/sunxi-spl.bin \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-sunxi-spl.bin
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-spl.bin
$(CP) $(PKG_BUILD_DIR)/u-boot-sunxi-with-spl.bin \
- $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-sunxi-with-spl.bin
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-u-boot-with-spl.bin
+ $(CP) uEnv.txt \
+ $(BIN_DIR)/uboot-$(BOARD)-$(1)/openwrt-$(BOARD)-$(1)-uEnv.txt
endef
define Package/uboot/install/template
diff --git a/package/boot/uboot-sunxi/uEnv.txt b/package/boot/uboot-sunxi/uEnv.txt
new file mode 100644
index 0000000000..e4fc0e19bf
--- /dev/null
+++ b/package/boot/uboot-sunxi/uEnv.txt
@@ -0,0 +1,5 @@
+fdt_high=ffffffff
+loadkernel=fatload mmc 0 0x46000000 uImage
+loaddtb=fatload mmc 0 0x49000000 dtb
+bootargs=console=ttyS0,115200 earlyprintk root=/dev/mmcblk0p2 rootwait
+uenvcmd=run loadkernel && run loaddtb && bootm 0x46000000 - 0x49000000
diff --git a/target/linux/sunxi/config-3.12 b/target/linux/sunxi/config-3.12
index b57168b2d8..d24d1c2092 100644
--- a/target/linux/sunxi/config-3.12
+++ b/target/linux/sunxi/config-3.12
@@ -67,7 +67,7 @@ CONFIG_CLKSRC_MMIO=y
CONFIG_CLKSRC_OF=y
CONFIG_CLONE_BACKWARDS=y
CONFIG_CMDLINE="console=ttyS0,115200 earlyprintk rootwait root=/dev/mmcblk0p2"
-CONFIG_CMDLINE_FORCE=y
+# CONFIG_CMDLINE_FORCE is not set
CONFIG_COMMON_CLK=y
CONFIG_COMPACTION=y
CONFIG_CONFIGFS_FS=y