aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-12-16 07:16:42 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-12-16 07:16:42 +0000
commit31d7d99e60fed8212c2379cad7141179e6eff4dc (patch)
treed891e60772f8350abe6784bef16e41fad62c126f
parent09fb8ac34c6f7bc427e83597600f91de766bd003 (diff)
downloadmaster-187ad058-31d7d99e60fed8212c2379cad7141179e6eff4dc.tar.gz
master-187ad058-31d7d99e60fed8212c2379cad7141179e6eff4dc.tar.bz2
master-187ad058-31d7d99e60fed8212c2379cad7141179e6eff4dc.zip
ar71xx: add kernel support for WD My Net N750
Signed-off-by: Felix Kaechele <heffer@fedoraproject.org> [juhosg: use a separate patch for kernel changes] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39077 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/config-3.101
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-mynet-n750.c196
-rw-r--r--target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch39
3 files changed, 236 insertions, 0 deletions
diff --git a/target/linux/ar71xx/config-3.10 b/target/linux/ar71xx/config-3.10
index f8323235b9..2d6f404006 100644
--- a/target/linux/ar71xx/config-3.10
+++ b/target/linux/ar71xx/config-3.10
@@ -52,6 +52,7 @@ CONFIG_ATH79_MACH_JA76PF=y
CONFIG_ATH79_MACH_JWAP003=y
CONFIG_ATH79_MACH_MR600=y
CONFIG_ATH79_MACH_MYNET_N600=y
+CONFIG_ATH79_MACH_MYNET_N750=y
CONFIG_ATH79_MACH_MYNET_REXT=y
CONFIG_ATH79_MACH_MZK_W04NU=y
CONFIG_ATH79_MACH_MZK_W300NH=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-mynet-n750.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-mynet-n750.c
new file mode 100644
index 0000000000..60f68cd6a1
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-mynet-n750.c
@@ -0,0 +1,196 @@
+/*
+ * WD My Net N750 board support
+ *
+ * Copyright (C) 2013 Felix Kaechele <felix@fetzig.org>
+ * Copyright (C) 2013 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/pci.h>
+#include <linux/phy.h>
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "nvram.h"
+
+
+/*
+ * Taken from GPL bootloader source:
+ * board/ar7240/db12x/alpha_gpio.c
+ */
+#define MYNET_N750_GPIO_LED_WIFI 11
+#define MYNET_N750_GPIO_LED_INTERNET 12
+#define MYNET_N750_GPIO_LED_WPS 13
+#define MYNET_N750_GPIO_LED_POWER 14
+
+#define MYNET_N750_GPIO_BTN_RESET 17
+#define MYNET_N750_GPIO_BTN_WPS 19
+
+#define MYNET_N750_GPIO_EXTERNAL_LNA0 15
+#define MYNET_N750_GPIO_EXTERNAL_LNA1 18
+
+#define MYNET_N750_KEYS_POLL_INTERVAL 20 /* msecs */
+#define MYNET_N750_KEYS_DEBOUNCE_INTERVAL (3 * MYNET_N750_KEYS_POLL_INTERVAL)
+
+#define MYNET_N750_WMAC_CALDATA_OFFSET 0x1000
+#define MYNET_N750_PCIE_CALDATA_OFFSET 0x5000
+
+#define MYNET_N750_NVRAM_ADDR 0x1f058010
+#define MYNET_N750_NVRAM_SIZE 0x7ff0
+
+static struct gpio_led mynet_n750_leds_gpio[] __initdata = {
+ {
+ .name = "wd:blue:power",
+ .gpio = MYNET_N750_GPIO_LED_POWER,
+ .active_low = 0,
+ },
+ {
+ .name = "wd:blue:wps",
+ .gpio = MYNET_N750_GPIO_LED_WPS,
+ .active_low = 0,
+ },
+ {
+ .name = "wd:blue:wireless",
+ .gpio = MYNET_N750_GPIO_LED_WIFI,
+ .active_low = 0,
+ },
+ {
+ .name = "wd:blue:internet",
+ .gpio = MYNET_N750_GPIO_LED_INTERNET,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button mynet_n750_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = MYNET_N750_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = MYNET_N750_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+ {
+ .desc = "WPS button",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = MYNET_N750_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = MYNET_N750_GPIO_BTN_WPS,
+ .active_low = 1,
+ },
+};
+
+static struct ar8327_pad_cfg mynet_n750_ar8327_pad0_cfg = {
+ .mode = AR8327_PAD_MAC_RGMII,
+ .txclk_delay_en = true,
+ .rxclk_delay_en = true,
+ .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+ .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+};
+
+static struct ar8327_led_cfg mynet_n750_ar8327_led_cfg = {
+ .led_ctrl0 = 0xc737c737,
+ .led_ctrl1 = 0x00000000,
+ .led_ctrl2 = 0x00000000,
+ .led_ctrl3 = 0x0030c300,
+ .open_drain = false,
+};
+
+static struct ar8327_platform_data mynet_n750_ar8327_data = {
+ .pad0_cfg = &mynet_n750_ar8327_pad0_cfg,
+ .port0_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+ .led_cfg = &mynet_n750_ar8327_led_cfg,
+};
+
+static struct mdio_board_info mynet_n750_mdio0_info[] = {
+ {
+ .bus_id = "ag71xx-mdio.0",
+ .phy_addr = 0,
+ .platform_data = &mynet_n750_ar8327_data,
+ },
+};
+
+static void mynet_n750_get_mac(const char *name, char *mac)
+{
+ u8 *nvram = (u8 *) KSEG1ADDR(MYNET_N750_NVRAM_ADDR);
+ int err;
+
+ err = ath79_nvram_parse_mac_addr(nvram, MYNET_N750_NVRAM_SIZE,
+ name, mac);
+ if (err)
+ pr_err("no MAC address found for %s\n", name);
+}
+
+static void __init mynet_n750_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+ u8 tmpmac[ETH_ALEN];
+
+ ath79_register_m25p80(NULL);
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(mynet_n750_leds_gpio),
+ mynet_n750_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, MYNET_N750_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(mynet_n750_gpio_keys),
+ mynet_n750_gpio_keys);
+ /*
+ * Control signal for external LNAs 0 and 1
+ * Taken from GPL bootloader source:
+ * board/ar7240/db12x/alpha_gpio.c
+ */
+ gpio_request_one(MYNET_N750_GPIO_EXTERNAL_LNA0,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "External LNA0");
+ gpio_request_one(MYNET_N750_GPIO_EXTERNAL_LNA1,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "External LNA1");
+
+ mynet_n750_get_mac("wlan24mac=", tmpmac);
+ ath79_register_wmac(art + MYNET_N750_WMAC_CALDATA_OFFSET, tmpmac);
+
+ mynet_n750_get_mac("wlan5mac=", tmpmac);
+ ap91_pci_init(art + MYNET_N750_PCIE_CALDATA_OFFSET, tmpmac);
+
+ ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_RGMII_GMAC0);
+
+ mdiobus_register_board_info(mynet_n750_mdio0_info,
+ ARRAY_SIZE(mynet_n750_mdio0_info));
+
+ ath79_register_mdio(0, 0x0);
+
+ mynet_n750_get_mac("lanmac=", ath79_eth0_data.mac_addr);
+
+ /* GMAC0 is connected to an AR8327N switch */
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+ ath79_eth0_pll_data.pll_1000 = 0x06000000;
+ ath79_register_eth(0);
+
+ ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_MYNET_N750, "MYNET-N750", "WD My Net N750",
+ mynet_n750_setup);
diff --git a/target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch b/target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch
new file mode 100644
index 0000000000..95fb687ea1
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -56,6 +56,7 @@ enum ath79_mach_type {
+ ATH79_MACH_MR600V2, /* OpenMesh MR600v2 */
+ ATH79_MACH_MR600, /* OpenMesh MR600 */
+ ATH79_MACH_MYNET_N600, /* WD My Net N600 */
++ ATH79_MACH_MYNET_N750, /* WD My Net N750 */
+ ATH79_MACH_MYNET_REXT, /* WD My Net Wi-Fi Range Extender */
+ ATH79_MACH_MZK_W04NU, /* Planex MZK-W04NU */
+ ATH79_MACH_MZK_W300NH, /* Planex MZK-W300NH */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -820,6 +820,16 @@ config ATH79_MACH_MYNET_N600
+ select ATH79_DEV_WMAC
+ select ATH79_NVRAM
+
++config ATH79_MACH_MYNET_N750
++ bool "WD My Net N750 board support"
++ select SOC_AR934X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_WMAC
++ select ATH79_NVRAM
++
+ config ATH79_MACH_MYNET_REXT
+ bool "WD My Net Wi-Fi Range Extender board support"
+ select SOC_AR934X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -67,6 +67,7 @@ obj-$(CONFIG_ATH79_MACH_JWAP003) += mach
+ obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
+ obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_N600) += mach-mynet-n600.o
++obj-$(CONFIG_ATH79_MACH_MYNET_N750) += mach-mynet-n750.o
+ obj-$(CONFIG_ATH79_MACH_MYNET_REXT) += mach-mynet-rext.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W04NU) += mach-mzk-w04nu.o
+ obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += mach-mzk-w300nh.o