aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-21 10:41:27 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-21 10:41:27 +0000
commit2d285a2fb74e6fcbf021c752f70a7430a798fca3 (patch)
treee7d1e24749aff06deee36ff4e3115b8f9566d663
parent7db482efdaaa5b33bdbad2e84623404b1e00f24a (diff)
downloadmaster-187ad058-2d285a2fb74e6fcbf021c752f70a7430a798fca3.tar.gz
master-187ad058-2d285a2fb74e6fcbf021c752f70a7430a798fca3.tar.bz2
master-187ad058-2d285a2fb74e6fcbf021c752f70a7430a798fca3.zip
uClibc for x86 targets and kernels >= 2.6.24 need to copy the right include files, remove this when there are no 2.6.23 left
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11893 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--toolchain/uClibc/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 8c02489b14..197f736d1e 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -64,6 +64,13 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/cris.*/cris/' \
)
+# Remove me when there are no 2.6.23 targets
+ifeq ($(findstring 86,$(ARCH)),86)
+ ifneq ($(LINUX_2_6_23),y)
+ UCLIBC_TARGET_ARCH:=x86
+ endif
+endif
+
define Build/Prepare/Snapshot
$(PKG_UNPACK)
rm -Rf $(PKG_BUILD_DIR)