aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-31 20:06:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-31 20:06:46 +0000
commit272d1962e4b2ab5874662c40dbaca5561dd10d04 (patch)
tree0f136f3b7a15ea7289504d10f7bfc235cfa0e3ec
parent6cbf36fcd7b9ca7a1583e9b610e713c46e6a62bd (diff)
downloadmaster-187ad058-272d1962e4b2ab5874662c40dbaca5561dd10d04.tar.gz
master-187ad058-272d1962e4b2ab5874662c40dbaca5561dd10d04.tar.bz2
master-187ad058-272d1962e4b2ab5874662c40dbaca5561dd10d04.zip
strip kernel modules automatically as well
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3870 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--rules.mk4
-rwxr-xr-xscripts/rstrip.sh6
2 files changed, 5 insertions, 5 deletions
diff --git a/rules.mk b/rules.mk
index a613beaf40..a94eee9cd1 100644
--- a/rules.mk
+++ b/rules.mk
@@ -110,9 +110,7 @@ IPKG_TARGET_DIR := $(PACKAGE_DIR)
IPKG:=IPKG_TMP=$(BUILD_DIR)/tmp IPKG_INSTROOT=$(TARGET_DIR) IPKG_CONF_DIR=$(STAGING_DIR)/etc IPKG_OFFLINE_ROOT=$(BUILD_DIR)/root $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
-RSTRIP:=STRIP="$(STRIP)" $(SCRIPT_DIR)/rstrip.sh
-RSTRIP_KMOD:=STRIP="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" $(SCRIPT_DIR)/rstrip.sh
-
+RSTRIP:=STRIP="$(STRIP)" STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" $(SCRIPT_DIR)/rstrip.sh
all:
.PHONY: FORCE
diff --git a/scripts/rstrip.sh b/scripts/rstrip.sh
index 023ae4e54f..f71aaaf4f9 100755
--- a/scripts/rstrip.sh
+++ b/scripts/rstrip.sh
@@ -15,12 +15,14 @@ TARGETS=$*
exit 1
}
-find $TARGETS -type f -not -name \*.o -not -name \*.ko -a -exec file {} \; | \
+find $TARGETS -type f -a -exec file {} \; | \
sed -n -e 's/^\(.*\):.*ELF.*\(executable\|relocatable\|shared object\).*, not stripped/\1:\2/p' | \
(
IFS=":"
while read F S; do
echo "$SELF: $F:$S"
- eval "$STRIP $F"
+ [ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && \
+ eval "$STRIP_KMOD $F" || \
+ eval "$STRIP $F"
done
)