aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-08-30 10:24:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-08-30 10:24:11 +0000
commit2303e0bb0de67a8930f3027da693de4ea2215f3c (patch)
tree884d2d0e48e1c6505ec93d2f8311d02fdad0b7c0
parent1daaf3174b6852606a817ce315213b76845b09c4 (diff)
downloadmaster-187ad058-2303e0bb0de67a8930f3027da693de4ea2215f3c.tar.gz
master-187ad058-2303e0bb0de67a8930f3027da693de4ea2215f3c.tar.bz2
master-187ad058-2303e0bb0de67a8930f3027da693de4ea2215f3c.zip
only run trap error code in the configure template, if the configure script was not found
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4715 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/package.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 311ec35a9c..ce3c4b6a1b 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -263,7 +263,7 @@ endef
define Build/Configure/Default
@(cd $(PKG_BUILD_DIR)/$(3); \
- [ -x configure ] && \
+ [ -x configure ] && { \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
@@ -287,7 +287,7 @@ define Build/Configure/Default
--infodir=/usr/info \
$(DISABLE_NLS) \
$(1); \
- true; \
+ } || true; \
)
endef