aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-02-04 06:10:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-02-04 06:10:57 +0000
commit13093b4fad0ecd9f431228e557cd81db0c9d3da9 (patch)
tree45294285ebb8df96d23567b279097cd72926d48e
parent207f4c59ac038b38f466eb1b41593784f48b1d61 (diff)
downloadmaster-187ad058-13093b4fad0ecd9f431228e557cd81db0c9d3da9.tar.gz
master-187ad058-13093b4fad0ecd9f431228e557cd81db0c9d3da9.tar.bz2
master-187ad058-13093b4fad0ecd9f431228e557cd81db0c9d3da9.zip
linux/modules: add support for Asix ax88179 USB-Gigabit Ethernet adapters
requested and tested by forum user OWonPi https://forum.openwrt.org/viewtopic.php?id=55495 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44256 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/linux/modules/usb.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 7498bcb014..431c7baa2c 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1027,6 +1027,23 @@ endef
$(eval $(call KernelPackage,usb-net-asix))
+define KernelPackage/usb-net-asix-ax88179
+ TITLE:=Kernel module for USB-to-Gigabit-Ethernet Asix convertors
+ DEPENDS:=+kmod-libphy
+ KCONFIG:=CONFIG_USB_NET_AX88179_178A
+ FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/ax88179_178a.ko
+ AUTOLOAD:=$(call AutoProbe,ax88179_178a)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-asix-ax88179/description
+ Kernel module for USB-to-Ethernet ASIX AX88179 based USB 3.0/2.0
+ to Gigabit Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,usb-net-asix-ax88179))
+
+
define KernelPackage/usb-net-hso
TITLE:=Kernel module for Option USB High Speed Mobile Devices
KCONFIG:=CONFIG_USB_HSO