aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-03-21 18:10:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-03-21 18:10:55 +0000
commit0b14b06a39f22d594994b91f1137d0b584ec8f73 (patch)
tree59e9866dde682757cc41000d9e56869f1eeafbc2
parent6be316a1dbb4790108340ae22cbb5c0c62ba4047 (diff)
downloadmaster-187ad058-0b14b06a39f22d594994b91f1137d0b584ec8f73.tar.gz
master-187ad058-0b14b06a39f22d594994b91f1137d0b584ec8f73.tar.bz2
master-187ad058-0b14b06a39f22d594994b91f1137d0b584ec8f73.zip
Enable profiles for adm5120
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6629 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/adm5120-2.6/profiles/100-Atheros.mk17
-rw-r--r--target/linux/adm5120-2.6/profiles/110-None.mk17
2 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/adm5120-2.6/profiles/100-Atheros.mk b/target/linux/adm5120-2.6/profiles/100-Atheros.mk
new file mode 100644
index 0000000000..029586848f
--- /dev/null
+++ b/target/linux/adm5120-2.6/profiles/100-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/adm5120-2.6/profiles/110-None.mk b/target/linux/adm5120-2.6/profiles/110-None.mk
new file mode 100644
index 0000000000..2fcfacde9f
--- /dev/null
+++ b/target/linux/adm5120-2.6/profiles/110-None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+