aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58b0fead..78c1caa1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -168,6 +168,11 @@ if (BUILD_GUI AND NOT BUILD_PYTHON)
message(FATAL_ERROR "GUI requires Python to build")
endif()
+if (BUILD_GUI)
+ # For higher quality backtraces
+ set(CMAKE_ENABLE_EXPORTS ON)
+endif()
+
find_package(PythonInterp 3.5 REQUIRED)
if (BUILD_PYTHON)
# TODO: sensible minimum Python version