aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Shah <davey1576@gmail.com>2018-06-18 13:11:53 +0200
committerDavid Shah <davey1576@gmail.com>2018-06-18 13:11:53 +0200
commitbb4c70381338e1a84920cc2d62648910528fee1c (patch)
treedb38f898150a48bf23fc9bea7a590273bd0bb746 /CMakeLists.txt
parent9a2692039a9f407b264421169d5f33b401a0f907 (diff)
downloadnextpnr-bb4c70381338e1a84920cc2d62648910528fee1c.tar.gz
nextpnr-bb4c70381338e1a84920cc2d62648910528fee1c.tar.bz2
nextpnr-bb4c70381338e1a84920cc2d62648910528fee1c.zip
cmake: Set EXCLUDE_FROM_ALL on Python module and tests
Signed-off-by: David Shah <davey1576@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8901d6cc..8f3c6183 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,10 +94,10 @@ foreach (family ${FAMILIES})
target_compile_definitions(nextpnr-${family} PRIVATE MAIN_EXECUTABLE)
# Add the importable Python module target
- PYTHON_ADD_MODULE(nextpnrpy_${family} ${COMMON_FILES} ${${ufamily}_FILES})
+ PYTHON_ADD_MODULE(nextpnrpy_${family} EXCLUDE_FROM_ALL ${COMMON_FILES} ${${ufamily}_FILES})
# Add any new per-architecture targets here
- add_executable(nextpnr-${family}-test ${${ufamily}_TEST_FILES} ${COMMON_FILES} ${${ufamily}_FILES})
+ add_executable(nextpnr-${family}-test EXCLUDE_FROM_ALL ${${ufamily}_TEST_FILES} ${COMMON_FILES} ${${ufamily}_FILES})
target_link_libraries(nextpnr-${family}-test PRIVATE gtest_main)
add_test(${family}-test ${CMAKE_CURRENT_BINARY_DIR}/nextpnr-${family}-test)