aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEddie Hung <eddieh@ece.ubc.ca>2018-07-30 18:14:40 -0700
committerEddie Hung <eddieh@ece.ubc.ca>2018-07-30 18:14:40 -0700
commit46b74696527d3b217070ff4820b537e0b989a00f (patch)
treeda95e6dc441eb8608cd77d1eea218ec9cb5f26fb /CMakeLists.txt
parent9c45f762c8280b5f7948df15554e54a38a896da2 (diff)
parent7da64ee167d518641a479cad1b660c608fb3dede (diff)
downloadnextpnr-46b74696527d3b217070ff4820b537e0b989a00f.tar.gz
nextpnr-46b74696527d3b217070ff4820b537e0b989a00f.tar.bz2
nextpnr-46b74696527d3b217070ff4820b537e0b989a00f.zip
Merge remote-tracking branch 'origin/master' into redist_slack
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41bd4aab..4c222d71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -182,12 +182,7 @@ foreach (family ${ARCH})
add_executable(nextpnr-${family} ${COMMON_FILES} ${${ufamily}_FILES})
install(TARGETS nextpnr-${family} RUNTIME DESTINATION bin)
target_compile_definitions(nextpnr-${family} PRIVATE MAIN_EXECUTABLE)
-
- if (BUILD_PYTHON)
- # Add the importable Python module target
- PYTHON_ADD_MODULE(nextpnrpy_${family} ${COMMON_FILES} ${${ufamily}_FILES})
- endif()
-
+
# Add any new per-architecture targets here
if (BUILD_TESTS)
aux_source_directory(tests/${family}/ ${ufamily}_TEST_FILES)
@@ -210,10 +205,6 @@ foreach (family ${ARCH})
set(family_targets ${family_targets} nextpnr-${family}-test)
endif()
- if (BUILD_PYTHON)
- set(family_targets ${family_targets} nextpnrpy_${family})
- endif()
-
# Include the family-specific CMakeFile
include(${family}/family.cmake)
foreach (target ${family_targets})