aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Shah <dave@ds0.me>2019-11-13 16:17:43 +0000
committerDavid Shah <dave@ds0.me>2019-12-27 10:44:29 +0000
commit240561c370c03ad33b2ac397369659a0b9a54c18 (patch)
treebf8cbb5564f74aa74c88c581aeb850878305d5b8 /CMakeLists.txt
parent25867e3f231cc8ffe3ce87e6f1af1ca1d4c46146 (diff)
downloadnextpnr-240561c370c03ad33b2ac397369659a0b9a54c18.tar.gz
nextpnr-240561c370c03ad33b2ac397369659a0b9a54c18.tar.bz2
nextpnr-240561c370c03ad33b2ac397369659a0b9a54c18.zip
3rdparty: Add json11
Signed-off-by: David Shah <dave@ds0.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8fa4ec0..54da5bdd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,7 +191,7 @@ if (BUILD_PYTHON)
endif ()
endif()
-include_directories(common/ json/ frontend/ ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+include_directories(common/ json/ frontend/ 3rdparty/json11/ ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
if(BUILD_HEAP)
find_package (Eigen3 REQUIRED NO_MODULE)
@@ -202,9 +202,10 @@ endif()
aux_source_directory(common/ COMMON_SRC_FILES)
aux_source_directory(json/ JSON_PARSER_FILES)
+aux_source_directory(3rdparty/json11 EXT_JSON11_FILES)
aux_source_directory(frontend/ FRONTEND_FILES)
-set(COMMON_FILES ${COMMON_SRC_FILES} ${JSON_PARSER_FILES} ${FRONTEND_FILES})
+set(COMMON_FILES ${COMMON_SRC_FILES} ${EXT_JSON11_FILES} ${JSON_PARSER_FILES} ${FRONTEND_FILES})
set(CMAKE_BUILD_TYPE Release)
if(MINGW)