aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2019-06-26 21:31:24 +0000
committerwhitequark <whitequark@whitequark.org>2019-06-26 21:31:24 +0000
commit1b3c8ea9c1384882063203f35f0f66f60025f62c (patch)
tree755f98529f884b7f7b8180e6175bdffcf31782d8 /CMakeLists.txt
parent640285755e4c59eb14c8664e10a62653f2892e15 (diff)
downloadnextpnr-1b3c8ea9c1384882063203f35f0f66f60025f62c.tar.gz
nextpnr-1b3c8ea9c1384882063203f35f0f66f60025f62c.tar.bz2
nextpnr-1b3c8ea9c1384882063203f35f0f66f60025f62c.zip
CMake: serialize chipdb generation by default.
Fixes #296.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ade76d60..9ec078e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ option(USE_OPENMP "Use OpenMP to accelerate analytic placer" OFF)
option(COVERAGE "Add code coverage info" OFF)
option(STATIC_BUILD "Create static build" OFF)
option(EXTERNAL_CHIPDB "Create build with pre-built chipdb binaries" OFF)
+option(SERIALIZE_CHIPDB "Never build chipdb in parallel to reduce peak memory use" ON)
set(link_param "")
if (STATIC_BUILD)
@@ -209,7 +210,7 @@ include(bba/bba.cmake)
foreach (family ${ARCH})
message(STATUS "Configuring architecture : ${family}")
string(TOUPPER ${family} ufamily)
- aux_source_directory(${family}/ ${ufamily}_FILES)
+ aux_source_directory(${family}/ ${ufamily}_FILES)
if (BUILD_GUI)
add_subdirectory(gui ${CMAKE_CURRENT_BINARY_DIR}/generated/gui/${family} EXCLUDE_FROM_ALL)
@@ -219,14 +220,14 @@ foreach (family ${ARCH})
add_executable(nextpnr-${family} ${COMMON_FILES} ${${ufamily}_FILES})
install(TARGETS nextpnr-${family} RUNTIME DESTINATION bin)
target_compile_definitions(nextpnr-${family} PRIVATE MAIN_EXECUTABLE)
-
+
# Add any new per-architecture targets here
if (BUILD_TESTS)
if (COVERAGE)
APPEND_COVERAGE_COMPILER_FLAGS()
set(COVERAGE_LCOV_EXCLUDES '/usr/include/*' '3rdparty/*' 'generated/*' 'bba/*' 'tests/*')
SETUP_TARGET_FOR_COVERAGE_LCOV(
- NAME ${family}-coverage
+ NAME ${family}-coverage
EXECUTABLE nextpnr-${family}-test
DEPENDENCIES nextpnr-${family}-test
)
@@ -247,7 +248,7 @@ foreach (family ${ARCH})
# Set ${family_targets} to the list of targets being build for this family
set(family_targets nextpnr-${family})
-
+
if (BUILD_TESTS)
set(family_targets ${family_targets} nextpnr-${family}-test)
endif()