aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/QtPropertyBrowser/examples/object_controller/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-11 18:22:20 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-11 21:30:22 +0200
commiteb392f649ea544742849e50d920be677d09aa344 (patch)
treed3032358009998a515874bcc368c7cef5f5882ae /3rdparty/QtPropertyBrowser/examples/object_controller/CMakeLists.txt
parentbe73894bea1c5719eccfad6b8c7e7ae44798a68a (diff)
downloadnextpnr-eb392f649ea544742849e50d920be677d09aa344.tar.gz
nextpnr-eb392f649ea544742849e50d920be677d09aa344.tar.bz2
nextpnr-eb392f649ea544742849e50d920be677d09aa344.zip
Added QtPropertyBrowser source
Diffstat (limited to '3rdparty/QtPropertyBrowser/examples/object_controller/CMakeLists.txt')
-rw-r--r--3rdparty/QtPropertyBrowser/examples/object_controller/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/3rdparty/QtPropertyBrowser/examples/object_controller/CMakeLists.txt b/3rdparty/QtPropertyBrowser/examples/object_controller/CMakeLists.txt
new file mode 100644
index 00000000..390d0173
--- /dev/null
+++ b/3rdparty/QtPropertyBrowser/examples/object_controller/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Tell CMake to run moc when necessary:
+set(CMAKE_AUTOMOC ON)
+
+# As moc files are generated in the binary dir, tell CMake
+# to always look for includes there:
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+SET(example_name object_controller)
+
+SET(KIT_SRCS
+ main.cpp
+ objectcontroller.cpp
+ )
+
+ADD_EXECUTABLE(${example_name} ${KIT_SRCS})
+TARGET_LINK_LIBRARIES(${example_name} ${PROJECT_NAME}) \ No newline at end of file