aboutsummaryrefslogtreecommitdiffstats
path: root/python/libghdl/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/libghdl/setup.py')
-rw-r--r--python/libghdl/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/python/libghdl/setup.py b/python/libghdl/setup.py
new file mode 100644
index 000000000..c7c3de80b
--- /dev/null
+++ b/python/libghdl/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+from config import __version__
+
+setup(
+ name='libghdl',
+ version=__version__,
+ description='Interface to ghdl, a VHDL analyzer',
+ long_description="""GHDL is a vhdl simulator and libghdl provides a low-level
+interface to the parser. This library gives access to the AST so that you can
+write tools like linters.
+""",
+ author='Tristan Gingold',
+ author_email='tgingold@free.fr',
+ url='http://github.com/ghdl/ghdl',
+ license='GPL-2.0-or-later',
+ package_dir={
+ 'libghdl': './'
+ },
+ packages=[
+ 'libghdl',
+ 'libghdl.thin',
+ 'libghdl.thin.vhdl'
+ ]
+)