aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPatrick Lehmann <Patrick.Lehmann@plc2.de>2021-01-15 07:31:59 +0100
committerGitHub <noreply@github.com>2021-01-15 07:31:59 +0100
commitd890f27e480cdb37428f1b7c4bb37475ed38348d (patch)
treeef94e9ac91446f661ede0db86cb295e9ec903477 /setup.py
parent4868294436574660552ccef50a5b0849559393de (diff)
downloadghdl-d890f27e480cdb37428f1b7c4bb37475ed38348d.tar.gz
ghdl-d890f27e480cdb37428f1b7c4bb37475ed38348d.tar.bz2
ghdl-d890f27e480cdb37428f1b7c4bb37475ed38348d.zip
Reworking pre-compile scripts for Windows (#1594)
* Updated pre-compile scripts for OSVVM. * Reworked script for Vivado. * Reworked script for ISE. * Reworked UVVM compile script. Cannot be tested due to missing feature in GHDL see #1593. * Reworked scripts for Altera, Intel and Lattice. * Updated module imports. * Adjusted warnings. * Read OSVVM package files from compile-order file 'osvvm.pro'. * Support OSVVM and OSVVMLibraries as source directory. * Added support for OSVVM models to precompile script. * First update to the pre-compile scripts documentation. * Minimized file headers and redundant documentation. Using PowerShell's feature to document files, functions and modules. * Updated README in precompile scripts directory. * license: update headers of pyGHDL, scripts/windows, libraries/vendors * Fixed ForegroundColor and InvocationName. Co-authored-by: umarcor <unai.martinezcorral@ehu.eus>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py45
1 files changed, 22 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index 6a00e3637..6cb231f50 100644
--- a/setup.py
+++ b/setup.py
@@ -1,39 +1,38 @@
# =============================================================================
-# ____ _ _ ____ _
-# _ __ _ _ / ___| | | | _ \| |
-# | '_ \| | | | | _| |_| | | | | |
-# | |_) | |_| | |_| | _ | |_| | |___
-# | .__/ \__, |\____|_| |_|____/|_____|
-# |_| |___/
+# ____ _ _ ____ _
+# _ __ _ _ / ___| | | | _ \| |
+# | '_ \| | | | | _| |_| | | | | |
+# | |_) | |_| | |_| | _ | |_| | |___
+# | .__/ \__, |\____|_| |_|____/|_____|
+# |_| |___/
# =============================================================================
-# Authors: Tristan Gingold
-# Patrick Lehmann
-# Unai Martinez-Corral
+# Authors:
+# Tristan Gingold
+# Patrick Lehmann
+# Unai Martinez-Corral
#
# Package installer: Python binding for GHDL and high-level APIs.
#
# License:
# ============================================================================
-# Copyright (C) 2019-2020 Tristan Gingold
+# Copyright (C) 2019-2020 Tristan Gingold
#
-# GHDL is free software; you can redistribute it and/or modify it under
-# the terms of the GNU General Public License as published by the Free
-# Software Foundation; either version 2, or (at your option) any later
-# version.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
#
-# GHDL is distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with GHDL; see the file COPYING. If not, write to the Free
-# Software Foundation, 59 Temple Place - Suite 330, Boston, MA
-# 02111-1307, USA.
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <gnu.org/licenses>.
#
# SPDX-License-Identifier: GPL-2.0-or-later
# ============================================================================
-#
+
from pathlib import Path
from re import compile as re_compile
from setuptools import setup as setuptools_setup, find_packages as setuptools_find_packages